Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Garage - Tools (http://www.hotrodders.com/forum/garage-tools/)
-   -   Compressor Problem... (http://www.hotrodders.com/forum/compressor-problem-206268.html)

S10xGN 09-28-2011 10:08 AM

Compressor Problem...
 
Hi All,

I have a 7.5 HP Northern brand 29 CFM compressor about 6 yrs old. For the past few months, the interstage safety valve pops off a couple times whenever the unit shuts off. I changed out the discharge/check valve and it still pops. To me, this would indicate the 2nd stage reeds are not seating off and the full discharge pressure (175 PSI) is bleeding back into the 1st stage (PSV set at 80 PSI). There is no other problem of note. I've priced a rebuild kit and it's over $600! A whole new pump assembly is $750. I'm planning on just leaving it as-is until it no longer keeps up. Any thoughts or ideas?

Thanks!

Russ

OneMoreTime 09-28-2011 10:25 AM

You may have a broken reed..i had one and got a piece of tempered spring stock from McMaster Carr and made a new reed..back to working now...only about 20$ IIRC..

Sam

S10xGN 09-29-2011 01:58 PM

I'm considering this, but IIRC the gasket kit for the heads was over $150. I may give it a shot after it cools off some...

Thanks!

Russ


All times are GMT -6. The time now is 02:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.