Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Cracked Head Leaking Head Gasket?
View Single Post
  #18 (permalink)  
Old 02-19-2013, 08:08 PM
skippy89's Avatar
skippy89 skippy89 is offline
Registered User
 
Last photo:
Join Date: Feb 2012
Location: Idaho
Age: 22
Posts: 42
Wiki Edits: 0

Thanks: 7
Thanked 3 Times in 2 Posts
the surging and most of the bubbles happen once i get up to operating temperature 210. I can see the coolant is flowing well, at least it appears to flow well. here is a video at idle while the thermostat is closed. You can also hear my surging idle in the video.
[IMG][/IMG]
I'll upload a video with the thermostat open and engine up to temperature once it finishes uploading to photobucket.

I checked the plugs and they still look ok i think. [IMG][/IMG]

I noticed the back of my intake gasket is leaking oil where it connects to the block. But before I fix that, I'm going to check the thermostat and run it with the thermostat off like you suggested 64nailhead.
If i continue to have bubbles I'll take it to the dealership and inform them off a possible bad head gasket. If i don't I'll fix the intake gasket. It also appears that one of my injectors is leaking, I'll go ahead and rebuild the injector and see if that fixes my bad idle. And as for the old engine, it was just worn out, the heads needed rebuilt, engine had 200,000 so was in need of a rebuild anyways, and didn't want to mix new heads with an old block and the new engine was a cheaper route. Radiator is the old one, I'm not sure if it's the original radiator or not, I am the second owner of this truck and didn't get much information from the owner that had it in Utah a good portion of the trucks life. which was about 160,000 liles
Reply With Quote