Damn im dumb need lots of help - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-09-2004, 11:12 PM
Brian Morency's Avatar
Hauling A55 BURNING GASS!!!
 

Last journal entry: bros car
Last photo:
Join Date: May 2004
Location: Plainfield, IL
Age: 28
Posts: 235
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
Damn im dumb need lots of help

yea just posted a horsepower question and thanx for the answer but i didnt give correct info. i own a 1988 firebird formula 305 i was told high output with a TBI and i dont know what kind of trans except it is going out soon. i needed to know the horsepower because i was told the car was fast but right now the motor mounts are broken or worn because it jumps when i punch it and when i tried to do a brake touqe today the rpms would not go up much and if i gave it lots of gas it would lose power i have no idea what is wrong and maybe some 1 else knows the answer and could help me out on what to do with this car. i dont like ricers thats why i bought this car and i want to fix it up.it also sat for 2years and i dont know what i should replace to make it run better. GOOD MOTOR THO.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-10-2004, 02:25 AM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
im guessing 170hp stock

if it were my car i would replace spark plugs, wires, cap, rotor, air filter, fuel filter, and any bad hoses/belts.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-10-2004, 11:22 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,654
Wiki Edits: 0

Thanks: 15
Thanked 58 Times in 55 Posts
If the car sat that long then the gas has long turned into crap, so it`s no surprise the car doesn`t run too well, replace all the things mentioned in the before post, also replace the oxygen sensors. When you do the tune up, get the best pieces you can afford, get spiral core plug wires and not the cheap parts store solid core wires, also take your time and route the plug wires correctly. a K&N air filter would also be of benefit. Have the TBI injectors cleaned professionally or get a few bottles of the best fuel injection cleaner you can buy and run it through a few tanks of of fuel. It would likely be a good idea to get a can of sea foam, pour it in the oil and let the car idle 15 minutes then change the oil and filter. I would also pour some sea foam in the fuel to help clean the system. Lastly, since the car sat so long, it would be a good idea to change the tranny fluid and filter, even if the tranny seems to be on it`s last legs, one case I seen where one sat up the filter turned to mush so it was restricting the amount of fluid the tranny could pull in, therefore it slipped and wouldn`t shift correctly.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-28-2004, 11:55 AM
bullheimer's Avatar
NEVER use credit cards!
 

Last journal entry: car with tt2's, (stockers going back on)
Last photo:
Join Date: Jan 2002
Location: North of Seattle
Posts: 2,529
Wiki Edits: 0

Thanks: 0
Thanked 5 Times in 4 Posts
Damn im dumb need lots of help

join the club
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-28-2004, 11:59 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,856
Wiki Edits: 5

Thanks: 20
Thanked 246 Times in 200 Posts
Re: Damn im dumb need lots of help

Quote:
Originally posted by bullheimer
join the club
You formin' a club, Bull?................my old lady says that I should join.
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-31-2004, 07:21 AM
Kevin45's Avatar
Just one of the guys
 

Last journal entry: Garage Toys
Last photo:
Join Date: Jul 2002
Location: Urbana, Ohio
Age: 57
Posts: 3,058
Wiki Edits: 0

Thanks: 1
Thanked 15 Times in 15 Posts
Quote:
i needed to know the horsepower because i was told the car was fast but right now the motor mounts are broken or worn because it jumps when i punch it and when i tried to do a brake touqe today the rpms would not go up much and if i gave it lots of gas it would lose power i have no idea what is wrong
Maybe instead of taking care of it you are just tearing it up. Why not check and SEE if the mounts are broke. Start fixing what ain't right.

Kevin
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 05-31-2004, 08:58 AM
Member
 
Join Date: Oct 2003
Location: mn
Age: 34
Posts: 344
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
check your fluids

the tranny is probally slipping cause it is low on fluid I baught an older camaro like that for the engine and didn't care about the trans so dumped in a little fluid to get it on the trailer then when i got home blew the first gear on the 700r4 trying to do a brake stand but it still smoked the tires in reverse. drop the pan change the fluid and fill her up is what else i would do.
Jesse
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 06-08-2004, 01:32 PM
Brian Morency's Avatar
Hauling A55 BURNING GASS!!!
 

Last journal entry: bros car
Last photo:
Join Date: May 2004
Location: Plainfield, IL
Age: 28
Posts: 235
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
ok thanx everyone but i just ran into a 1984 camaro for sale only $500 and it was a friends so i know everything about it.he just bought a 03' mach1 that he's taking to the track today sapposed to run 13.1 but i dont know hes not the best shifter out there.the camaro has a 350 out of an elcamino that ran 13.4 in the camaro 13.9,has a 350turbo trans and is in great condition just needs a new rear main seal. I think its a steal so for now the formula project is on hold for about 2 months unless i find some one to buy it.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 06-09-2004, 03:42 PM
Rubberman2003's Avatar
Member
 
Last photo:
Join Date: Sep 2002
Location: Ohio
Age: 29
Posts: 806
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Nice find Brian,just dont get to many projects at once.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.