Danger danger..lay off the dupli-color - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-18-2004, 03:10 PM
Sandflea427SS's Avatar
Anything with a throttle
 
Last photo:
Join Date: Apr 2003
Location: South Central Pa
Posts: 440
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Danger danger..lay off the dupli-color

I just went through four cans of Dupli-color semi-gloss black. The engine enamel is working fine. But, the regular dupli-color enamel is having problems. There is a problem with the spray mechanism on the can. There is a little pin under the finger pad (at the top of the nozzle), The pin sinks down into the nozzle base causing erratic flow. Sometimes the nozzle won't spray at all. Sometimes the paint leaks out under the nozzle. Sometimes the nozzle sprays with different pressure. One can even sunk the pin after painting three inches. Brand new can. I was able to nurse two wounded cans, but the other two I couldn't use because of the mess it was making. Oh yeah, this stuff is $4 a can too.
I love the stuff....Just hold off for a while untill they find and fix the problem!!!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-18-2004, 03:34 PM
Member
 
Last photo:
Join Date: Jun 2003
Location: Tulsa, Oklahoma
Age: 32
Posts: 64
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have run into the same problem before. There is an easy solution however. Find a can of just about anything that sprays well, pull the nozzle off, and put it on the can you are trying to spray.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-18-2004, 04:28 PM
Hot Rod Hellion's Avatar
Member
 
Join Date: Feb 2004
Location: Little Rock
Age: 37
Posts: 81
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have had much better results with Plastikote myself.

Plastikote #203 universal gloss black engine enamel is DA BOMB!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-18-2004, 10:06 PM
Checy_Guy's Avatar
Member
 
Last photo:
Join Date: Jan 2004
Location: Canada
Posts: 108
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
you think 4$ is allout its like 10 bucks in canada damn prices here suck.
__________________
Chevy-Rules
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-18-2004, 10:31 PM
Sandflea427SS's Avatar
Anything with a throttle
 
Last photo:
Join Date: Apr 2003
Location: South Central Pa
Posts: 440
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Whoa guy......I'll buy a bunch for ya...where do I send the package....
hey Cheez...not so easy to fix.....It isn't the nozzle...I wish it was that easy...The pin sinks down into the plastic extension coming out of the can that attaches to the nozzle. That's the problem....
remember not all nozzles are the same anymore.....Why was there a need to change...? oh well....
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-18-2004, 11:03 PM
OddRodder's Avatar
CORNFED and INBRED !?!
 
Join Date: Jan 2003
Location: Springfield, MO.
Age: 53
Posts: 612
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Sometimes it's the paint itself!!! Has it been on the shelf a long time ? Has it ever been frozen? I have had the same problem with other brands of paint!! But, the pin type nozzle seems to be the worst!
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-20-2004, 12:34 AM
Sandflea427SS's Avatar
Anything with a throttle
 
Last photo:
Join Date: Apr 2003
Location: South Central Pa
Posts: 440
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If it was an odd color I might say yes...But, it was Semi-gloss black. Maybe one of the most sold paint cans. Freezing...there is a great deal of freezing at this time of year in good ole PA.....Maybe just a bad batch...lazy factory worker......????
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.