Dash gauges and lights flickering. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-01-2012, 08:19 PM
Registered User
 
Join Date: Sep 2011
Location: saskatoon
Posts: 46
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Dash gauges and lights flickering.

Hi i have a '66 impala and the problem is very noticeable at night and very annoying. The gauges lights, signal light indicators, etc all flicker on and off constantly. Its probably just bad connections, and wanted to know what is a good solution for this. Where are the wiring connections that i should be looking to for corrosion/ bad connection, or is there a place i can buy new wiring kit for the car? Thank you.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-01-2012, 08:33 PM
Registered User
 
Join Date: Aug 2006
Location: Alexandria, VA
Posts: 1,754
Wiki Edits: 0

Thanks: 4
Thanked 65 Times in 63 Posts
It sounds like it may be the dash panel ground wire that is loose. I don't know where they connected the panel ground wire on your car, but on my truck it is connected to a bolt on the emergency brake mechanism. (Which is bolted to the body of the truck.)

Bruce
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-02-2012, 03:54 AM
EOD Guy's Avatar
Registered User
 
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 2,031
Wiki Edits: 0

Thanks: 1
Thanked 126 Times in 117 Posts
X2 with the loose ground wire.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-02-2012, 07:05 AM
Registered User
 

Last journal entry: Still running strong
Join Date: Dec 2011
Location: Lakehills Tx
Posts: 539
Wiki Edits: 0

Thanks: 49
Thanked 40 Times in 38 Posts
Check your alt.connection also.I had the same issue,some how some body didnt tighten up the alt.stud nut.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
tail lights and dash lights quit ashman Electrical 5 08-30-2010 12:27 AM
79 TA: dash lights and tail lights fuse keeps blowing Gladis Electrical 6 12-01-2007 12:43 AM
flickering dash lights tjh211 Electrical 5 05-06-2007 05:28 PM
Replacing the lights with gauges grandprix601 Electrical 3 01-03-2004 10:30 AM
Flickering Lights horvath Electrical 7 05-19-2003 03:52 PM


All times are GMT -6. The time now is 07:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.