detonating tbi ? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-12-2013, 09:26 AM
Registered User
 
Last photo:
Join Date: Oct 2010
Location: az
Posts: 204
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
detonating tbi ?

I purchased a tbi conversion on the net for my 56 chev. 283 ci. stock cam eng.
The ecu is supposed to be from a 305/350 ci. However I have had a problems for a week. The kit came with a new dist. but mostly used parts such as HARNESS, coil, and most sensors except 02 sensor. The eng. started up, but it
sounded like it was detonating. Which I`m sure it is. I could not time it and make any difference with detonating. after I tried a few more times with timing adjustment, it then would not fire at all. Called co. and they said the dist module was bad, got a new one, made no diff. then they sent another dist. and it started up ok but detonation was still there. This 283 ci eng. was rebuilt 1500 miles ago and has run great until this conversion. Does anyone know for sure if the chip in the ecu could cause a problem like detonation?
I know that the 283 is not an eng. that most guys convert to tbi, but it should work like a 305 eng. ? Help please.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-12-2013, 10:17 AM
Registered User
 

Last journal entry: New Rev wheels and BFG KDW II tires
Last photo:
Join Date: May 2013
Location: South Central MN
Posts: 524
Wiki Edits: 0

Thanks: 93
Thanked 117 Times in 109 Posts
Did you do anything else with the tbi adaptor? If you didn't I would imagine that might have something to do with how it's running. It would also help you you mentioned what kit you bought.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-12-2013, 11:05 AM
Registered User
 
Last photo:
Join Date: Oct 2010
Location: az
Posts: 204
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
yes, I reworked the adapter to match manifold, and there does not appear to be any vacuum leaks.
Here is the Ebay item # of tbi kit 271285477375 Thanks
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-12-2013, 11:08 AM
Registered User
 
Last photo:
Join Date: Oct 2010
Location: az
Posts: 204
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
PS. The adapter now fits the large openings on manifold and cover the small holes
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-12-2013, 11:14 AM
Registered User
 

Last journal entry: New Rev wheels and BFG KDW II tires
Last photo:
Join Date: May 2013
Location: South Central MN
Posts: 524
Wiki Edits: 0

Thanks: 93
Thanked 117 Times in 109 Posts
Oops. Edit post.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-12-2013, 11:48 AM
Registered User
 
Last photo:
Join Date: Oct 2010
Location: az
Posts: 204
Wiki Edits: 0

Thanks: 5
Thanked 0 Times in 0 Posts
warrperformancellc (94 TBI kit without 700r4 hookup. Please paste this seller in ebay, and it should show kit. Thanks
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Silverado TBI swap to 427 TBI chupp Engine 4 04-14-2011 09:54 AM
350 TBI to 454 TBI Swap NAIRB Engine 1 10-16-2004 03:51 PM
Detonating Slant3 Engine 0 09-14-2004 04:39 PM
305 TBi camaro what is the cfm of the tbi 89camaroman Engine 0 10-05-2003 09:21 PM
need help to turn a 350 tbi into a rollerized 383 tbi Bradless Engine 2 01-03-2003 10:13 PM


All times are GMT -6. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.