Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   Dim dash lights (http://www.hotrodders.com/forum/dim-dash-lights-224246.html)

dmonson83 09-21-2012 07:02 PM

Dim dash lights
 
I have a 1950 ford and just recently got the dash lights working. Only problem the original gauge cluster is still dim but the clock and defroster switch are bright. The headlight switch appears to be the original 6 volt. Does anyone have any ideas how to make it brighter. I looked into another 6 volt switch or a universal switch but dont know which is the better way to go

poncho62 09-21-2012 08:06 PM

I have a later model switch in my 51 F1 Ford and one gauge cluster is still much brighter than the other....I think it is more the positioning of the bulbs more than anything else.

timothale 09-21-2012 08:39 PM

correct bulb.?
 
there are different candle power bulbs that will fit in the socket.

EOD Guy 09-23-2012 02:40 PM

I'm thinking you prob need to check the wiring to the lights for corroded connections

Joe G 09-24-2012 05:26 PM

You didn't mention if you had checked or replaced all the instrument panel lamps already, so if you haven't, that's another thing to check. Over time, some of the metal from the bulb's filament gets deposited on the inside of the bulb glass, making it dark. In extreme cases, the bulb ends up looking like a mirror and barely emits any light at all.

Also, Make sure all the bulbs are present and accounted for.

http://i159.photobucket.com/albums/t...B/DarkBulb.jpg

You might also try running a temporary ground wire to the instrument cluster just to see if it improves things.

Hope this helps....:thumbup:

dmonson83 09-27-2012 08:31 PM

just took the car out for its first night time drive since the lights were fixed. you can just make out the speedometer and the other gauges. the clock is bright and the defroster is bright . a couple of new 1895 bulbs were added earlier. the headlight switch is the original and the resistor is bad. is there a possibility if buying a universal headlight switch that might solve my problem

rickman2k 09-27-2012 10:07 PM

sounds like a bad ground to the one that's dim

Rocketbird 10-20-2012 05:01 PM

I just had the same issue with my 49 ford coupe.

First thing would be to make sure your getting the right voltage from off your switch. If that's good this was the fix I did to my gauge lights.

The gauge had these glass caps that are supposed to be a purple colour. Over time, I guess mixed with the temperature of the bulb the glass colour starts to get darker till its almost a black colour. Thus the dim light. The glass cap for the bulb was supposed to work like a black light that would react with the gauge's paint and help it to glow. Of course that would have been when the paint for the gauge and the glass caps were new and would have worked well.

You can take the gauge off (label and unhook everything) and if you look where the opening for the lights are there should be a purple or almost black lens there that you can take out and your lights in your 5 in 1 dash gauge should be bright again.

To take the glass out, (with the whole gauge on my work bench)I took out one of the 4 small gauges for access, where the light goes into the back of the gauge there are these little tabs for the bracket that holds the glass in place, bend the tabs to release the bracket and I used the opening where the gauge I removed was allowing me to be able to pull the bracket and lens out. Then do it over again till they are all removed. (replacing the small gauges before taking a new one out.

You may want to use a coloured bulb as the level of brightness is distracting at night.

This was what I did to fix my issue. I hope this helps


All times are GMT -6. The time now is 08:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.