Dim dash lights - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-21-2012, 07:02 PM
Registered User
 
Join Date: Aug 2012
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Dim dash lights

I have a 1950 ford and just recently got the dash lights working. Only problem the original gauge cluster is still dim but the clock and defroster switch are bright. The headlight switch appears to be the original 6 volt. Does anyone have any ideas how to make it brighter. I looked into another 6 volt switch or a universal switch but dont know which is the better way to go
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-21-2012, 08:06 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 61
Posts: 16,791
Wiki Edits: 5

Thanks: 19
Thanked 238 Times in 194 Posts
I have a later model switch in my 51 F1 Ford and one gauge cluster is still much brighter than the other....I think it is more the positioning of the bulbs more than anything else.
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-21-2012, 08:39 PM
Registered User
 
Last wiki edit: General Motors transmissions Last photo:
Join Date: Mar 2006
Location: near Yellowstone park
Posts: 4,043
Wiki Edits: 27

Thanks: 10
Thanked 208 Times in 195 Posts
correct bulb.?

there are different candle power bulbs that will fit in the socket.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-23-2012, 02:40 PM
EOD Guy's Avatar
Registered User
 
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 1,883
Wiki Edits: 0

Thanks: 1
Thanked 91 Times in 84 Posts
I'm thinking you prob need to check the wiring to the lights for corroded connections
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-24-2012, 05:26 PM
Joe G's Avatar
Registered user
 
Last photo:
Join Date: Nov 2008
Location: St. Paul, MN
Posts: 563
Wiki Edits: 0

Thanks: 71
Thanked 24 Times in 23 Posts
You didn't mention if you had checked or replaced all the instrument panel lamps already, so if you haven't, that's another thing to check. Over time, some of the metal from the bulb's filament gets deposited on the inside of the bulb glass, making it dark. In extreme cases, the bulb ends up looking like a mirror and barely emits any light at all.

Also, Make sure all the bulbs are present and accounted for.



You might also try running a temporary ground wire to the instrument cluster just to see if it improves things.

Hope this helps....
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 09-27-2012, 08:31 PM
Registered User
 
Join Date: Aug 2012
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
just took the car out for its first night time drive since the lights were fixed. you can just make out the speedometer and the other gauges. the clock is bright and the defroster is bright . a couple of new 1895 bulbs were added earlier. the headlight switch is the original and the resistor is bad. is there a possibility if buying a universal headlight switch that might solve my problem
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 09-27-2012, 10:07 PM
Registered User
 
Last photo:
Join Date: Jul 2012
Location: Russellville, Arkansas
Age: 50
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
sounds like a bad ground to the one that's dim
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 10-20-2012, 05:01 PM
Registered User
 
Last photo:
Join Date: May 2011
Location: Ontario, Canada
Posts: 43
Wiki Edits: 0

Thanks: 6
Thanked 0 Times in 0 Posts
I just had the same issue with my 49 ford coupe.

First thing would be to make sure your getting the right voltage from off your switch. If that's good this was the fix I did to my gauge lights.

The gauge had these glass caps that are supposed to be a purple colour. Over time, I guess mixed with the temperature of the bulb the glass colour starts to get darker till its almost a black colour. Thus the dim light. The glass cap for the bulb was supposed to work like a black light that would react with the gauge's paint and help it to glow. Of course that would have been when the paint for the gauge and the glass caps were new and would have worked well.

You can take the gauge off (label and unhook everything) and if you look where the opening for the lights are there should be a purple or almost black lens there that you can take out and your lights in your 5 in 1 dash gauge should be bright again.

To take the glass out, (with the whole gauge on my work bench)I took out one of the 4 small gauges for access, where the light goes into the back of the gauge there are these little tabs for the bracket that holds the glass in place, bend the tabs to release the bracket and I used the opening where the gauge I removed was allowing me to be able to pull the bracket and lens out. Then do it over again till they are all removed. (replacing the small gauges before taking a new one out.

You may want to use a coloured bulb as the level of brightness is distracting at night.

This was what I did to fix my issue. I hope this helps
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
accessory lights dim when head lights turned on 36int Electrical 8 04-10-2011 11:59 AM
1985 Dim Lights on Dash BillH 85 Electrical 3 09-07-2010 06:20 PM
Dim head lights CrashFarmer2 Electrical 3 03-05-2008 02:38 PM
No lights on dim lanierledford Electrical 5 09-29-2006 05:37 PM
Dim Dash lights Torino1 Electrical 2 01-14-2006 05:36 AM


All times are GMT -6. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.