Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Disappointment with new cam/head swap
View Single Post
  #11 (permalink)  
Old 07-06-2009, 02:49 PM
Custom10's Avatar
Custom10 Custom10 is offline
my KARMA ran over my DOGMA
 

Last journal entry: SS
Last photo:
Join Date: May 2009
Location: Saskatchewan, Canada
Age: 50
Posts: 1,101
Wiki Edits: 0

Thanks: 18
Thanked 31 Times in 27 Posts
What is the casting number of your vortec heads? (under the valve cover)
New, recent GM Parts heads or the original '96 to 2000 GM OEM L-31 truck heads, or after market copy?
Apparently the new/recent GM service heads are from Mexico and do not flow the same as the old OEM L-31 heads or make as much power. (typically down 20hp according to some engine builders dyno results)

Hmmm I did not know this about the mexico castings, my 062 castings were from scoggin dickys and there was "assembled in mexico" in the casting? 20hp is a huge deal. I researched the hell out these heads and that info never came up before now, makes me wonder...I would like to know more about this

I have recently done the same vortec swap and have a comp XE 12-235-2 grind which is a 210/218 dur @ 0.050 with 447/462 lift and 111 lsa 4x4 cam. Also used 41 thou gasket, performer EPS with edy 1405 carb, 1 inch spacer, headers. Cam is straight up and run 12 deg initial adv, 45 total with the vac adv can, 3 spd tranny with 3.73 in a 72 C10. I am getting very good performance compared to my old 76cc heads, other than some valve train noise which I can't make go away. Also I made the mistake of not measuring the piston to deck height so I don't know the squench or the true CR. It will smoke the tires without dumping the clutch and break the tires loose when shifting hard into 2nd. There is something a-miss with your setup for sure.
Reply With Quote