Do i need to put in special lube for a posi? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-26-2006, 07:23 PM
Registered User
 
Last photo:
Join Date: Mar 2006
Location: ocklawaha,Fl
Age: 25
Posts: 223
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Do i need to put in special lube for a posi?

took a rear end of a cutlass 12 bolt, 3.2??? gear ratio . better than what i had in there. any ways there was a tag that said put limited slip oil in there. should i? what would i use?? whats the best?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-26-2006, 07:40 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 61
Posts: 16,776
Wiki Edits: 5

Thanks: 19
Thanked 228 Times in 188 Posts
Yes.............you can get it at GM or most auto parts srores
__________________
Ontario Rodders
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-26-2006, 10:16 PM
Member
 
Last photo:
Join Date: May 2003
Location: Shreveport LA
Age: 64
Posts: 5,103
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Go the GM parts counter and ask for a bottle of Positraction Additive. If he doesn't know what you're talking about, go to the next guy.

Pour it into the rear end before you put the oil in.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-27-2006, 04:00 PM
Registered User
 
Join Date: Aug 2006
Location: Alexandria, VA
Posts: 1,724
Wiki Edits: 0

Thanks: 4
Thanked 62 Times in 60 Posts
Most of the parts stores (Autozone, etc.) also carry it, back in the area where they have axle grease and gear lubricant.

Bruce
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-28-2006, 01:13 PM
Registered User
 
Join Date: Oct 2006
Location: rochester,ny
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Posi Lube

I have had my 68 Chevelle with a 12 bolt posi init and have tried other posi additives from name brand oil companies and I have drained them back out because of heat and "snapping and popping" after the rear was up to temp. Without altering the clutches in the rear Just adding the GM lube It is fine and never acts up. It is a small 4 -8 oz bottle used to be clear plastic.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-29-2006, 07:58 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 7,976
Wiki Edits: 1659

Thanks: 255
Thanked 85 Times in 82 Posts
Mobil 1 syn gear oil will solve the problem of needing an additive.... it has worked well for me.


__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Posi Rear end gear oil problem stinky jinx Transmission - Rearend 16 05-14-2006 02:02 PM
Engine Assembly Lube ? bowtieorbust Engine 11 11-09-2004 11:24 AM
Anything special to put roller cam in 400 block? sb72elcamino350 Engine 1 04-09-2004 11:12 PM
Where can i get a posi Dreadlord Transmission - Rearend 9 01-20-2004 08:15 AM


All times are GMT -6. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.