Do I need the vacuum modulator? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-02-2004, 04:36 PM
65 streeter's Avatar
New Member
 
Join Date: Jun 2004
Location: Orange Co, So Cal
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Do I need the vacuum modulator?

Hey Gang,

With the vacuum modulator hooked up it seems to shift to early.. especially from 2nd to 3rd. I'm going to adjust the modulator but I ran it with the vacuum disconnected and liked the shift points unconnected. Here is the goop:

Just put in 3.73's, TH350 tranny with TCI 3000 stall 10 in converter, motor is a 350 cid with above 420 horses (Edelbrock performer rpm set-up). I have the KD cable adjusted right as it kicks down nice.

I don't know how it should all feel as it is all a new set-up to me.

Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-02-2004, 09:44 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,655
Wiki Edits: 0

Thanks: 15
Thanked 59 Times in 56 Posts
I would use it, as for shift points, after you adjust the modulator, if the shift points still aren`t to your happiness get a adjustable govenor kit. you can taylor your upper rpm shift points with it.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-02-2004, 11:37 PM
65 streeter's Avatar
New Member
 
Join Date: Jun 2004
Location: Orange Co, So Cal
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I adjusted the modulator and it helped. I'm only getting about 8 or 9 hg's in drive (idle at 800/900) because of the cam... I'm thinking that is a contributor. It is an Art Carr tranny that I picked up from a friend who had low miles on it (he is going with a 200R4).

I read another post about low vacuum modulators that are available and I may try that. I'd like to read up on the adjustable governor kit... where would I find that?

Please note... I am not a tranny guy. Appreciate the help.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-03-2004, 11:20 PM
65 streeter's Avatar
New Member
 
Join Date: Jun 2004
Location: Orange Co, So Cal
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Well I was playing with the speedo gear and yep, dropped it inside. So took the rear housing off and much to my surprise I found a plastic tooth missing from the governor drive. So I'm taking the old governer, which shifted where I wanted it, and putting it in it's place. I'm also going to swap the speedo drive gears.

Does anyone know the trick to getting the speedo drive gear clip to let go my eggo? Don't want to break nothin.

Just found another post archive that stated how the clip works. So looks like I have to hold the tips of the clip down and gently knock the gear off.

Just found this post:

th350 Speedometer problem

It helped. Hopefully I'm okay to tap the gear loose as it won't move by hand.

Last edited by 65 streeter; 07-03-2004 at 11:20 PM.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-04-2004, 02:03 PM
65 streeter's Avatar
New Member
 
Join Date: Jun 2004
Location: Orange Co, So Cal
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Changed the governor and the speedo gears... runs great, shifts where I want it and the speedo seems accurate... life is good!
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.