Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Drill thermostat
View Single Post
  #1 (permalink)  
Old 04-20-2005, 10:25 PM
78 monte 78 monte is offline
E.T. divided by $ spent= Speed
 
Last photo:
Join Date: May 2002
Location: NYS america's unwiped butt
Age: 34
Posts: 1,858
Wiki Edits: 0

Thanks: 0
Thanked 5 Times in 5 Posts
Drill thermostat

Again w/ the dodge 2.2 questions.But I'm haveing a hell of a time fingering this out.
So far I've replaced the thermostat(#4 or 5 now),put a new radiator cap(16lb stock),found the electric fan motor bad and replaced it,and replaced the coolant sensor.And filled the system w/ 50/50 mix.I evan fill the system w/ the nose up in the air(recomended for 2.2 by a dodge site)to purge the air outta the water box(as they call it) were the stat sits.
The engine isn't boiling over now.But while I was filling the radiator the car ran up to 3/4 on the gauge befor the fan kicked on.Is this right??
The normal temp is 1/4 on gauge.
I took it out right after this and it ran at normal temp the whole time.
Now when I took it out after it had cooled completely down.It would run the gauge up to almost full after 3mi of driving then pop down to normal and stay there.This is what it has done since I've owned it(3yrs)and everytime I replace the stat it cures it for 3mo then starts again(2 others told me they have the same problem).Cept this time its still doing it w/ a new stat.
Think if I drill 2 holes in the base of the stat,it will alow enough water to pass through so it don't have to overheat befor the stat opens??

(if ya read my headgasket post about a week ago I think the foam I saw was just setament from burnt coolant.The motor has no water in oil,Steam out exhuast,discolored coolant(oil) and also isn't bubbling in the coolant now,other than when its starting to boil form the stat problem)

Last edited by 78 monte; 04-20-2005 at 10:34 PM.
Reply With Quote