Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Dyno disaster
Thread: Dyno disaster
View Single Post
  #1 (permalink)  
Old 02-28-2005, 09:26 PM
lust4speed's Avatar
lust4speed lust4speed is offline
Member
 
Last photo:
Join Date: Oct 2003
Location: Inland Empire, SOCAL
Posts: 424
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Dyno disaster

We were running the '67 GTO on the chassis dyno at the local technical institute, and had completed two abbreviated runs without incident. We then went pedal to the metal on a full load 3,000 to 6,000 run in high gear. At 5,300 RPM and 129 MPH all hell broke loose. The student behind the wheel and the student running the dyno switch evacuated the dyno room at a full run, leaving the instructor and I to run in and shut the car down and hit the stop on the dyno. Half a driveshaft makes a fair amount of racket coasting down from that speed as it thrashes the underside of the car. Surprisingly, the 3" exhaust system took almost all of the blunt trama, and while the exhaust pipes were squished flat, the floorpan suffered very little. The driveshaft safety loop held the force for awhile until the bowing driveshaft became too short to stay inside. The trans totally seperated around the bellhousing and in front of the tailshaft area. Note that the driveshaft had absolutely no rust, and there was no vibration at all until the instant catastrophic failure. Totally destroyed was the Turbo 400 trans, stock driveshaft with HD universal joints, and the 3" exhaust system.

Attached Thumbnails
Click image for larger version

Name:	Failed_parts.jpg
Views:	1012
Size:	90.7 KB
ID:	4068  

Last edited by M&M CUSTOM; 03-01-2005 at 11:51 AM.
Reply With Quote