ecm testing - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-26-2005, 04:01 PM
Member
 
Join Date: Jun 2003
Location: north East
Posts: 42
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ecm testing

I suspect that my ecm is bad can anyone suggest any places where I can have it tested. How much does testing an ecm cost?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-26-2005, 04:16 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc Here ,

Welcom to the Forum!

What are the symptoms ?

What Vehicle? Year, make model and engine size?

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations

Last edited by docvette; 10-26-2005 at 04:34 PM.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-26-2005, 05:22 PM
Member
 
Join Date: Jun 2003
Location: north East
Posts: 42
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Its an 89 camaro and the problem is intermittent. Sometimes it runs rough more noticable at idle and when the car is up to operating temp. I checked all my ignition primary and secondary wiring no fault found.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-26-2005, 05:39 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,

Have you tried pulling codes with a reader?

If you don't have one , go to your local Kragens or auto zombie, and they can run them for you..

You may not have an ECM or ignition problem at all..Depending on type of induction, you could have failing fuel pump, Clogged Fuel filters, air in the shrader valve, dirty injector (s)

You could also have a heat failure on a dizzy module..or a failing , dirty or Condensation locked Coil...

Pull the codes and see what it says..before you spend mega bucks on everything else..

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-27-2005, 04:29 PM
78novaman's Avatar
The AMC, FORD, & CHEVY Guy??!!
 
Last wiki edit: Improving fuel economy
Last journal entry: Finally on the road
Last photo:
Join Date: Nov 2002
Location: Central Ohio
Age: 31
Posts: 299
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 2 Posts
All the 'zones around here only test OBDII vehicles ('96-up).

Your best bet is to find a pal that has an analyzer that can read OBDI GM, or visit the f-body forums to find out how to pull the codes using a paperclip (watching the dummy lights flash). http://www.f-body.com/

With that old of a car it could be any number of problems that, unfortunately, are going to be very difficult to troubleshoot online without specific codes.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey DocVette...ECM question Kevin45 Electrical 2 06-23-2005 06:49 PM
testing turn signal socket??? classic keith Electrical 11 04-11-2005 04:57 PM
90 Camaro RS Electrical Problem JulianSerna Electrical 8 05-19-2004 02:32 PM
Blowing ECM Fuse When Ignition Is Turned On aberg12012 Electrical 2 02-09-2004 04:31 PM
ecm harness corsair Electrical 3 07-08-2003 10:02 AM


All times are GMT -6. The time now is 10:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.