Edelbrock 1406 issue - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-11-2013, 07:01 PM
GTNMUDY's Avatar
Registered User
 
Join Date: Apr 2013
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Edelbrock 1406 issue

I have a 1406 Edelbrock on a 355 SBC. About a week ago I noticed my idle adjustment changed and was idleing at a higher rpm rate than before. I also noticed the left side of the exhaust was not as smooth as the right side.

I had no issues with rpm above idle or past the transition point to higher rpm.

I went to check my idle mixture screws and when I turned the right idle screw inward the engine would stumble, reduce rpm and quit (normal).

However when I put the mixture screw back to where it was and start the engine I then turned the left mixture screw inward the engine would not quit. It would reduce and idle bad but not quit like the right side did.

I removed the card from the manifold, removed the mixture screws and shot cab cleaner and high air pressure into each side. Still same problem.

The carb spacer I am using has 4 holes and does isolate the right and left banks of the maniford.

Any ideas before I tear into the carb?

Larry

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-11-2013, 07:49 PM
Denny's Avatar
34 chevy truck 410 merc power
 
Last photo:
Join Date: Sep 2005
Age: 66
Posts: 943
Wiki Edits: 0

Thanks: 137
Thanked 144 Times in 139 Posts
Sounds like you have some junk in the bowl clogging a jet.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-12-2013, 07:05 AM
Irelands child's Avatar
Registered User
 
Last wiki edit: Ford engine specifications Last photo:
Join Date: Jan 2005
Location: Upstate New York
Posts: 4,989
Wiki Edits: 8

Thanks: 20
Thanked 245 Times in 220 Posts
Edelbrock carbs along with their 'parent' carbs, Carters are very susceptible to ANY dirt. Pull it off, flush it and blow it out well, add a very good inline fuel filter (not one of the cheapie glass or plastic junkers) and reinstall. There is a good chance that if you only pull the top horn off you will need to just replace the base gasket. This is all there is to a 1405 or 1406:



That is a 1405 with the choke option along with another above it waiting it's turn in the bath.

.....and back on the car:



Dave W
__________________
Irelands child
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-12-2013, 12:16 PM
Registered User
 
Last photo:
Join Date: May 2008
Location: ohio
Posts: 1,613
Wiki Edits: 0

Thanks: 54
Thanked 67 Times in 64 Posts
I have two different 350 small blocks and one has a holley double pumper 650 and the other a holley 600 vacuum secondary and I run dual plain intake manifolds on both and both of my holley carbs do similar things and they are brand new. The driver side is less sensitive then the passenger side and responds a litte less then the other but both will kill the engine if your turn them in far enough but it does it quicker on the passenger side then the driver side. I run a 4 hole spacer on both engines as well.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
edelbrock 1406 tuning gavinjames Engine 2 07-16-2013 05:57 AM
1406 edelbrock problems Blackdog Engine 18 05-11-2013 05:20 PM
Edelbrock 1406 elwaupo Engine 5 12-19-2011 06:46 PM
1406 edelbrock carb help hddave1 Hotrodding Basics 4 04-30-2011 02:44 PM
Edelbrock 1406 help please tommytempest Engine 13 03-12-2006 10:21 PM


All times are GMT -6. The time now is 08:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.