Edelbrock Bog? - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 07-23-2010, 07:59 PM
Registered User
 
Join Date: Jul 2010
Location: Las Vegas/NV
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 454headache
Solved it. I upped the secondary jets from .98 to .101 (12% richer). But what really helped the most and cured the issue was adding molten lead to the air valve counter weights.

...
Never tried using molten leads but would want to keep it in case the need for it arise. Is it sold by some other name as well?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 07-23-2010, 08:13 PM
454headache's Avatar
Registered User
 
Last photo:
Join Date: Apr 2009
Location: Washington
Age: 34
Posts: 237
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hehe, what I meant by "molten lead" is that I melted down some lead, drilled holes in the air valve weights, poured the lead in the holes, waited for it to cool, and presto, no more bog. Edelbrock either needs to offer different weight air valves or disclose this severe short coming before you purchase a none-AVS performer.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 bog from a stop..edelbrock parts. need HeLP spacechimp Engine 19 07-14-2009 12:51 PM
edelbrock 600 bog at low rpm's. HELP!!!! hickey's got a yami Engine 5 08-31-2008 03:32 PM
Edelbrock 750cfm, Bog at quick WOT NoEgoMan100 Hotrodding Basics 8 06-05-2006 05:43 PM
Edelbrock Bog bigman348 Engine 12 10-23-2004 05:44 PM
Edelbrock 600cfm bog trouble wickster Engine 4 03-14-2004 06:09 PM


All times are GMT -6. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.