Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   edelbrock carb on 305 (http://www.hotrodders.com/forum/edelbrock-carb-305-a-219429.html)

ted200008 05-15-2012 02:34 PM

edelbrock carb on 305
 
i have a 305 in a 84 el camino. i put a new intake and carb on. i think its a 650cfm carb. it runs great, but if i leave it sit for more than like 10 minutes, after driving it for awhile, and go to start it back up. it acts like its flooded and i get a lot of black carbon smoke out of the exhaust when it does finally fire up. is this too big of a carb or?? it runs great other than that. also it has a streight pipe going all the way back. i get a lot of black carbon smoke?? anyone have any suggestions?

F-BIRD'88 05-15-2012 03:13 PM

The carb body is getting too hot. Install a edelbrock wood carb spacer
and block off or restrict the manifold heat riser passages to tame the heat under the plenum.

common issue with edelbrock carbs and aluminum manifolds.
Excess carb heat.

Your local gas station may still be pumping "winter gas"
Winter gas is designed for easy cold weather starting
and tends to vapourize way to easily in warm spring weather.
Creating Hot start issues.

cobalt327 05-15-2012 03:21 PM

Quote:

Originally Posted by ted200008
i have a 305 in a 84 el camino. i put a new intake and carb on. i think its a 650cfm carb. it runs great, but if i leave it sit for more than like 10 minutes, after driving it for awhile, and go to start it back up. it acts like its flooded and i get a lot of black carbon smoke out of the exhaust when it does finally fire up. is this too big of a carb or?? it runs great other than that. also it has a streight pipe going all the way back. i get a lot of black carbon smoke?? anyone have any suggestions?

If it has an electric choke you also might want to check to see that the choke's not closing (adjusted too rich) after a short cool-down. Not too likely, but it has happened.

ted200008 05-15-2012 08:38 PM

choke
 
the choke had vibrated way rich. i put it back and tightened it dont. it got rid of a lot of the black smoke and ran a lil better but it still has some trouble starting right up after it sits for more than 10 mins. im gonna try that carb spacer because i think it is getting too hot at the carb. but any other suggestions would be great too!!

John long 05-15-2012 08:43 PM

If your float is a little high to will exacerbate the problem........I have waited months to be able to use that word. :rolleyes: :mwink:

John L


All times are GMT -6. The time now is 07:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.