Edelbrock performer RPM - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-15-2004, 03:03 PM
1985fiero's Avatar
1972 Nova Turbo Lsx
 
Last photo:
Join Date: Jan 2004
Location: New Albany Ohio
Age: 30
Posts: 88
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Edelbrock performer RPM

Doing my first engine build and am using a performer rpm intake on my sbc and have three threaded holes for stuff. two at front of engine by water ports on either side of the water inlet filler. and then there is one at the middle of the intake just behind carb. can anyone please let me know what all these are for. I know that one is for a water temp sensor possibly.


but really need some help


thanks
dan

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-15-2004, 04:51 PM
Frisco's Avatar
Glad To Be Here
 
Last photo:
Join Date: Nov 2002
Location: Canton, North Carolina
Age: 72
Posts: 2,244
Wiki Edits: 0

Thanks: 0
Thanked 8 Times in 8 Posts
Re: Edelbrock performer RPM

Quote:
Originally posted by 1985fiero
Doing my first engine build and am using a performer rpm intake on my sbc and have three threaded holes for stuff. two at front of engine by water ports on either side of the water inlet filler. and then there is one at the middle of the intake just behind carb. can anyone please let me know what all these are for. I know that one is for a water temp sensor possibly.


but really need some help


thanks
dan
The front two are for the coolant temperature sending unit. Use whichever one you want and put a plug in the other. The one behind the carb is for manifold vacuum. You can use it for that or plug it.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-15-2004, 05:55 PM
65chevymike's Avatar
Member
 
Last photo:
Join Date: Apr 2004
Location: indiana
Posts: 48
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
one in front,heater hose return,others like he said ^^
least thats how mines hooked up.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-17-2004, 05:03 AM
mustangdude947's Avatar
Resident Jury-Rig Expert
 
Last photo:
Join Date: Dec 2003
Location: Overland Park, KS
Age: 26
Posts: 61
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thats how I hooked mine up and it worked fine
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.