edelbrock pro flo injection wont start after running out of fuel - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-19-2009, 09:09 PM
Registered User
 
Join Date: Nov 2009
Location: earth
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
edelbrock pro flo injection wont start after running out of fuel

Nothing else changed, ran out of fuel, put more in and now it won't start anymore, cranks but won't fire, 377 all aluminum built small block with edelbrock pro flo I injection system

Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-20-2009, 12:17 AM
redlightning's Avatar
Member
 
Last photo:
Join Date: Aug 2004
Location: TN
Age: 49
Posts: 1,082
Wiki Edits: 0

Thanks: 3
Thanked 9 Times in 3 Posts
Can you hear the fuel pump run?



and..............Welcome to the site.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-20-2009, 03:27 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,764
Wiki Edits: 0

Thanks: 4
Thanked 427 Times in 366 Posts
Quote:
Originally Posted by jemonah
Nothing else changed, ran out of fuel, put more in and now it won't start anymore, cranks but won't fire, 377 all aluminum built small block with edelbrock pro flo I injection system

Thanks
FI fuel pumps need the passing of fuel to cool them, check the pump it may be dead.

Another enemy is dirt in the tank, running low to out of fuel tends to to suck the crud into the pump, the inlet filter may be plugged, the pump damaged, or the outlet filter plugged. If it got past these places the next stop is regulator and injectors.

Running out of fuel is never good for the components that deliver it to the engine, but with fuel injection it can be a deadly and costly sin.

Bogie
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-20-2009, 03:59 PM
Registered User
 
Join Date: Dec 2004
Location: San Jose Ca
Age: 62
Posts: 472
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is the fuel pump wired thru a relay with the computer turning on the relay not the fuel pump ? If the computer runs the fuel pump as in the early system this sometimes burns out the computer.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pinging on 03 Chevy 5.3 Engine in Suburban bry21317 Engine 42 10-02-2011 07:35 PM
running whole new fuel system ?'s maxkroll Hotrodding Basics 2 02-12-2009 10:59 AM
edelbrock pro flo/ holley commander htwheelz67 Engine 6 04-05-2004 07:53 AM
Edelbrock Pro Flo 3500 Questions TurboS10 Engine 9 09-12-2003 09:26 AM
Edelbrock performer fuel pump on a 77 gmc 400CI? 77chevy400 Engine 1 07-09-2003 12:17 AM


All times are GMT -6. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.