Edelbrock Qudarjet secondaries - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-05-2002, 01:37 PM
New Member
 
Join Date: Feb 2002
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post Edelbrock Qudarjet secondaries

Having a hard time figuring out how to get my secondaries to kick in sooner and with more gusto. Anyone with a clue pls. chime in.

This is a new Edelbrock quadrajet 795 cfm w/ vaccum secondaries.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-05-2002, 02:47 PM
Member
 
Join Date: Mar 2002
Location: Alabama
Age: 56
Posts: 144
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

I need more info not familiar with edelbrock carbs. but they all work the same. do they have a spring to replace for the secondaries :p if they do triaL and error lighter spring until you find the right respose.hope this helps ( wrenchturner )

[ May 05, 2002: Message edited by: wrenchturner ]

[ May 05, 2002: Message edited by: wrenchturner ]</p>
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-06-2002, 12:10 PM
New Member
 
Join Date: May 2002
Location: MT
Posts: 29
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Wink

step down to a weaker spring and re- jet
:p
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-07-2002, 05:58 AM
New Member
 
Join Date: Feb 2002
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I found on the left side where there is a small set screw that holds the secondary butterfly spring in check. Cut that loose and use a screwdriver to set the secondary butterfly spring tension did 1/2 the trick. The spring was set way to high. Now on to re-jetting the secondaries. Thanks for the clues guys. Unfortunately I'm beginning to see that I might have been better off with a double pumper in consideration of the Muncie wide ration 4 speed?

I'm just beginning to crack the potential of this engine...but am trying to do it right...wires, coil, curve etc. Too bad gas in these parts is so inconsistent. One bad tank and I'm back to square one.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-15-2002, 04:47 PM
72 chevy's Avatar
Member
 
Join Date: May 2002
Location: Plainville,K.S.
Posts: 242
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

i hear ya 56, gas is very inconsistent up here in north central ks.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-15-2002, 05:04 PM
FASTFORD's Avatar
Member
 
Last photo:
Join Date: Apr 2002
Posts: 469
Wiki Edits: 0

Thanks: 0
Thanked 29 Times in 18 Posts
Post

dont be to upset. i have had, seen and heard of similar problems with holley. its still a little trial and error with either carb. the edge with edelbrock is the ease of making changes. hang in there and take your time. also you could contact edelbrock with as much info as possible and they will tell you what spring and jets to start out with.
www.edelbrock.com
update us with the results. luck.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 05-15-2002, 08:15 PM
Member
 
Join Date: Mar 2002
Location: Melrose FL
Posts: 291
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Once you get teh Q-jet tuned right, the beauty is they usually stay there. Holley is a lot easier to tune, but I hear a lot more guys having to go back in and re-tune periodically.

Good luck with it.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 05-17-2002, 04:46 AM
New Member
 
Join Date: Feb 2002
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Man, it's the little things. First, the distributor had slipped and there was a small vaccum leak at the carb base plate. She's purring NOW!

I'm at 10 degrees advance on the distributor (not counting vaccum advance) and NO ping whatsoever. Gonna start moving that up until I her some pre-detonation. Sound good?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.