Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Edelbrock / Weber / Cater Carburetor Problems..... (http://www.hotrodders.com/forum/edelbrock-weber-cater-carburetor-problems-2968.html)

SirSpeedy 07-19-2002 01:07 PM

Edelbrock / Weber / Cater Carburetor Problems.....
 
OK, Here is my situation:

SBC in a '32 Ford, 9:1 Goodwrench crate, smooth idle cam(~.450" or so) dual plane intake, Edelbrock/Weber AFB-style 600cfm carb. Simple little motor.

Now, in the primaries of the carb, there are two smaller "booster venturis", they hang in the middle of the primaries from the sides of the carb body. In the middle of the boosters, there is a brass port that the fuel flows out of. My problem is even at idle, fuel drips out both boosters. I mean like 2-3 big drips per second. Needless to say, the engine runs pretty poorly with this condition.

From all my experience as well as input from others, this is a symptom of a stuck needle and seat. We have checked the N&S, adjusted the float hieght up and down, etc. And not just on the one carb, we have tried three different carbs on this engine, two rebuilts and a new one. We also have tried two different fuel pumps(thinking too much pressure), and lastly added a regulator. The supply side is definately not the problem.

We also pulled the primary metering rods, took the springs OUT of the carb, then dropped them back in...so they were fully seated in the primary jets...no change...drip-drip-drip.

With each of these changes, the problem is exactly the same. Like I said these are fresh rebuilts from NCS, as well as a brand new one that was operating perfectly on antoher engine a few weeks ago.

So what do you all think? I think I've given a pretty accurate and complete description of the problem.

4 Jaw Chuck 07-19-2002 08:36 PM

Open up the idle air bleeds a few thousands of an inch at a time until the drip stops. This is best done with a complete set of number drills (60-100) and a pin vise. If you do not have these tools/drills then don't attempt this procedure, you can easily destroy the carb if you do this improperly. With Holley carbs you can usually solve this problem with a venturi booster change.

I have also seen a modification where a tiny hole was drilled in the tip of the brass tube, this effectively reduces the pulsation of vacuum that is drawing the fuel out and make the idle circuit less sensitive to these fluctuations. Mind you this was done to a very radical alky sprint car engine, I would not recommend this mod for your mildly tuned engine.

Are you positive the air bleed circuit is perfectly clean? This circuit can be impossible to clean on a used carb and usually means a scrap carb if it is filled with the yellow/white fuzzy's. Air flowing throught the holes does not guarantee it is clean. Double check everything before drilling anything, I doubt you need to drill the bleeds with such a mildly tuned engine. Use a long horse hair or fishing line to probe the circuit (DO NOT USE metal wire!!). I have used ultrasound cleaning to good effect to salvage scrap carbs before but with only a 50% success rate when the bleeds are compromised. I know some people have pulled the bleeds and cleaned them and then pressed in new bleeds but make sure you can get new ones before doing this, they can be fabricated, but not easily (ever drill a 0.007" hole?).

SirSpeedy 07-21-2002 07:58 PM

Hey,

I would go for that, if it was on just one carb, but three?

I am at a real loss on this one.

KULTULZ 07-22-2002 01:33 AM

Did you actually measure fuel pressure with an accurate gauge? At idle and higher RPM? Do you have an in-line fuel filter mounted?

Did you replace the needle and seat? Maybe a bad float? Doubt it on three different carbs, but you never know. You have a HOLLEY laying around to check it's operation?

EDELBROCK has a hotline...maybe a quick call will answer your question.

[ July 22, 2002: Message edited by: KULTULZ ]</p>

SirSpeedy 07-22-2002 07:47 PM

Yes, pressure was around 8-9psi at idle....after adding a regulator set at 5psi, checked it again to verify it was 5psi.

There is an inline filter, is is in the rear just after the tank, Ford stainless steel EFI=style.

Three seperate carburetors.....We let it set today to work on other projects. Going to get back on it in the morning. I'm thinking of running a vacuum test in the morning also.

I'll keep you guys posted.
-T

general 09-01-2002 12:05 AM

yeah; same problem here 650 carter idles like **** and loads up. tried everything, latest test was removing idle bleed screws one at a time while running one had no effect other killed engine. will be using 4 jaw chucks suggestion next. do you think i use sonic cleaner at the jewelry store?

4 Jaw Chuck 09-01-2002 12:19 AM

General, use heavy duty caustic carb cleaner in the ultrasound bath, do it in a very well ventilated area...the fumes will kill ya. Sounds like you have a blocked idle air port or idle fuel slot feed passage.

Sir speedy your carbs are what kind again? your description doesn't make sense to me,"Edelbrock/Weber AFB-style 600cfm carb." Are these Carter two barrel carbs...six pack setup? What cfm per carb? <img src="confused.gif" border="0">

fatfen48 09-01-2002 01:19 PM

When you change three carbs and the problem remains I would look some where else. How fast does it idle? Faster than normal? Cam you adjust the mix screws? If you hold your hand over the carb inlet lightly does idle it smooth out? you may have a vac leak.


All times are GMT -6. The time now is 09:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.