Engine help - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-21-2004, 07:36 PM
eM-K's Avatar
New Member
 
Join Date: Oct 2004
Location: dublin,NH
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Engine help

I was driving my camaro yesterday... and i was aware that it was idling really low so i was planning on changing the spark plugs. I had to brake hard and my car stalled or something and the wheel locked (its an automatic) and i had to stop and start again. Are these connected? It is something i need to get fixed. What caused it? Also im getting a sputtering sound from my exhaust after its been idling... Are these seperate things or are they all connected in some way.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-21-2004, 08:09 PM
Siggy_Freud's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Dec 2003
Location: Portland, Oregon
Age: 29
Posts: 2,371
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Give us the specifics of the engine. Size, what kind of carb, where the timing is, etc. All of these could be and probably are involved. Done a vacuum check? Fuel pressure okay? Start with the simple things.
__________________
Bringing history and technology together.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-21-2004, 08:23 PM
oldschoolrods's Avatar
Member
 

Last journal entry: Engine Compartment
Last photo:
Join Date: Dec 2003
Location: Lancaster, Pennsylvania
Age: 28
Posts: 806
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It sounds like you have some carb issues to me...what do the plugs look like?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-21-2004, 08:47 PM
Novaman78's Avatar
Kill It & Grill It
 

Last journal entry: New door panels
Last photo:
Join Date: Oct 2003
Location: Bonne Terre Missouri
Age: 28
Posts: 219
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Check the plugs if they are black and sooty then your running rich. This is what it sounds like to me as i just had this problem with my car.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-21-2004, 09:12 PM
MI2600's Avatar
Member# 3287
 

Last journal entry: Vortec Heads
Last photo:
Join Date: Jul 2002
Location: N. Muskegon, MI
Posts: 2,632
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
"The wheel locked"...steering wheel?
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.