Engine Help. Engine Turns over Hard, like siezed yet runs awsome. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-05-2008, 02:24 PM
Registered User
 
Join Date: Oct 2008
Location: Landis
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Engine Help. Engine Turns over Hard, like siezed yet runs awsome.

Hi there, I need help. I have just put a new 383 Stroker in my 1993 Chevy Silverado. I put a Holley 670 Throttle body on and Roller rockers at 3/4 turn from Zero lash. I changed the starter from another old truck and its doing the same thing. I tried timing the truck but when it starts the distributor advances itself, to what it wants. Its hard turning over but when it starts it has lots of jam. Any suggestions would help. Something tells me its the timing, but im not sure. I would take the sparkplugs out and try turning it over but I have alluminum heads and headers on the truck so its extremly hard to take the plugs out. and put them back in.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-05-2008, 05:45 PM
406 bug's Avatar
9.82 @ 139mph
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Nov 2007
Location: phoenix, arizona
Posts: 582
Wiki Edits: 1

Thanks: 0
Thanked 1 Time in 1 Post
Maybe too much initial advance. Put a timing light on and see where to begin. Could be poor ground - check starter.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-05-2008, 06:28 PM
espo1980's Avatar
If it doesn't fit force it!
 
Join Date: Sep 2008
Location: Baltimore MD
Age: 33
Posts: 28
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Engine Help. Engine Turns over Hard, like siezed yet runs awsome.

Is there a ground strap connecting the engine to the body? Without it, it could do what your saying.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-05-2008, 06:38 PM
71 c-10's Avatar
just a kid and his truck
 
Last photo:
Join Date: Sep 2003
Location: VA
Age: 27
Posts: 351
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
to set base timing on these you have to disconnect the ignition jumper that is on the firewall under the panel that says junction block. The connector is a single brown wire with a round connector, you un plug it then you can set your timing and then plug it back in.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
hot side, 350 tpi engine runs hot on one bank? Ellisb Engine 16 10-27-2002 06:28 AM
Engine stumbles only when I make U turns dion Engine 6 07-27-2002 06:54 PM
Engine turns over but will not start?? Jim Weeks Engine 13 04-06-2002 11:18 AM
engine turns off when the car is put in to gear t623 Engine 4 02-03-2002 09:23 AM
engine turns off when the car is put in to gear t623 Engine 4 01-24-2002 07:33 PM


All times are GMT -6. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.