Engine Knocking sounds - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-10-2005, 04:00 PM
Registered User
 
Join Date: Jun 2005
Location: U.K.
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Engine Knocking sounds

Hello to everyone, I would be happy if someone could help me with some ideas where my engine knocking sounds maybe coming from, I have just had my Mustang shipped from Colorado to London U.K. picked it up from the port three days ago and it went fine. It has developed a knocking noise, it only does it when warm and it doesn't do it all the time it never does it at idle but when it starts knocking it will keep knocking for a couple of seconds if the revs drop to idle it seems to be at the same speed as the engine and usually starts at about 30mph - 40mph the oil pressure seems to be lower (but it is the original gauge ie 40 years old). The engine is a rebuilt 302, comp cams dur at .050 int218exh224, edlebrock 4 barrel carb(electric choke), headers. Just before i shipped the car i had all the exhaust valves replaced as they were burnt out (not sure why)and it was smoking a bit. The car now runs on 95oct and I am sure it is running a bit rich. I'm thinking of changing the oil and filter as I am not sure what oil the engine shop put in after the valve job. if anyone has any ideas I would welcome them, the funny thing is it doesn't knock all the time.
Cheers
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-11-2005, 02:27 AM
RCastle's Avatar
Come Home Safe Soldier
 

Last journal entry: Headers
Last photo:
Join Date: Aug 2004
Location: Louisville,Kentucky
Age: 43
Posts: 848
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It is homesick.I am going through the same ordeal as you with my SBC.I have checked several things and have had some good suggestions on other things also to check.Here is a link,get to work.Read These
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-11-2005, 03:48 AM
Registered User
 
Join Date: Jun 2005
Location: U.K.
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I read your thread earlier RCastle there are some very good suggestions, I want to try the easier things first as parts will be a nightmare over here. The car will eventually live in my home country of New Zealand, but the idea is to drive around Europe before sending it home. Parts are alot easier to source in N.Z., over here (London) everyone has 1.6 litre cars and very few V8's. I am hoping the oil is the problem as the engine has less than 1000 miles on it since rebuild and less than 300miles since the valves been replaced and guides my guess is the engine shop that did the work has put the cheapest oil they could find in. So far I am having bad luck with this ford, while it was at the port in long beach someone broke into it and broke the windscreen and speaker grill and stole my brand spanking new $2500 stereo system and they messed up the interior at the same time. My watch also packed up at the same time as picking up the car.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-11-2005, 07:39 AM
RCastle's Avatar
Come Home Safe Soldier
 

Last journal entry: Headers
Last photo:
Join Date: Aug 2004
Location: Louisville,Kentucky
Age: 43
Posts: 848
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I just had my starter go out completely yesterday,just got a new one and put it on a few moments ago. I hope that was my problem,as it was shorting out from the solenoid to the starter body.Damn,that sux with the stereo and stuff. I hate a theif with no end.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-11-2005, 08:14 AM
Registered User
 
Join Date: Jun 2005
Location: U.K.
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The theft wasn't so bad I can get new audio here it's trying to replace the bits they broke and the rips on the brand new interior etc.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
the history of chevy v8's savman1 Hotrodders' Lounge 43 03-02-2012 06:57 PM
SBC 350 superiority rebuttle...was:POWERED BY CHEVY, WRITTEN ON A FORD, (from 'Engine Oldsmolac911 Hotrodders' Lounge 50 01-12-2011 10:00 PM
Build for Hp or Torque? Venturat Engine 76 09-23-2008 10:22 AM
engine makes crackling sounds novadan Engine 7 04-15-2005 03:57 PM
Some questions about a Ford SHO Kaylah General Rodding Tech 11 02-21-2004 09:25 AM


All times are GMT -6. The time now is 03:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.