Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Engine Squeak :( (http://www.hotrodders.com/forum/engine-squeak-163938.html)

BowTiePride 08-25-2009 01:24 PM

Engine Squeak :(
 
There is a squeak that sounds like it is at-par with engine speed. It's a 355 (350 bored .030 over), with mild performance additions (I can explain if necessary), and a 2speed powerglide trans, in a 67 Impala 4dr. I was told that it might be the flywheel but I thought I tightened the bolts on damn good. Any ideas? Thanks a million, she's my daily driver and it's driving me crazy!!!!

ssmonty 08-25-2009 05:24 PM

Get a 2ft piece of tubing small enough to fit in your ear to localize the sound.
Your flywheel may be a bit warped and rubbing on something.
ssmonty

BowTiePride 08-25-2009 10:39 PM

Hmmm, I shall check that tommorow!! If I'm in drive with the brake on, and elevate the idle by pressing the gas slightly, it will go away

dawg 08-26-2009 06:06 AM

flexplate should be torqued down btw.
not just wrenched down.
Are you sure it not a glazed fan belt?

BowTiePride 09-03-2009 12:31 AM

It definately wasn't a fan belt, and wasn't flywheel either :( but I guess that's a good thing! It was my transmission sifter linkage. There's a part attached to the transmission that's spring loaded, and the shifter linkage was squeaking against the trans, so I cut a thin square out of a plastic coffee tin lid and slid it between. Squeak= no more :")


All times are GMT -6. The time now is 06:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.