Engine Squeak :( - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-25-2009, 12:24 PM
BowTiePride's Avatar
Chevy to the death!
 
Join Date: Nov 2008
Location: Calgary, Canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Engine Squeak :(

There is a squeak that sounds like it is at-par with engine speed. It's a 355 (350 bored .030 over), with mild performance additions (I can explain if necessary), and a 2speed powerglide trans, in a 67 Impala 4dr. I was told that it might be the flywheel but I thought I tightened the bolts on damn good. Any ideas? Thanks a million, she's my daily driver and it's driving me crazy!!!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-25-2009, 04:24 PM
Registered User
 
Last photo:
Join Date: Mar 2007
Location: Corinth, MS
Posts: 591
Wiki Edits: 0

Thanks: 0
Thanked 25 Times in 24 Posts
Get a 2ft piece of tubing small enough to fit in your ear to localize the sound.
Your flywheel may be a bit warped and rubbing on something.
ssmonty
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-25-2009, 09:39 PM
BowTiePride's Avatar
Chevy to the death!
 
Join Date: Nov 2008
Location: Calgary, Canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hmmm, I shall check that tommorow!! If I'm in drive with the brake on, and elevate the idle by pressing the gas slightly, it will go away
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-26-2009, 05:06 AM
dawg's Avatar
NAVY VETERAN
 
Last photo:
Join Date: Aug 2004
Location: Colebrook Connecticut
Age: 55
Posts: 901
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
flexplate should be torqued down btw.
not just wrenched down.
Are you sure it not a glazed fan belt?
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-02-2009, 11:31 PM
BowTiePride's Avatar
Chevy to the death!
 
Join Date: Nov 2008
Location: Calgary, Canada
Posts: 95
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
It definately wasn't a fan belt, and wasn't flywheel either but I guess that's a good thing! It was my transmission sifter linkage. There's a part attached to the transmission that's spring loaded, and the shifter linkage was squeaking against the trans, so I cut a thin square out of a plastic coffee tin lid and slid it between. Squeak= no more :")
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
the history of chevy v8's savman1 Hotrodders' Lounge 43 03-02-2012 06:57 PM
Build for Hp or Torque? Venturat Engine 76 09-23-2008 10:22 AM
Engine alignment ssmonty Engine 9 07-22-2008 10:10 PM
SF oil???? n-gin Engine 6 07-09-2008 01:37 PM
Why high RPM's on the oval tack? steveyb4342 Engine 25 05-23-2007 07:50 AM


All times are GMT -6. The time now is 01:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.