engine temp is hot - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-28-2010, 02:02 PM
never satisfied's Avatar
Registered User
 
Join Date: Aug 2010
Location: lehigh valley
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
engine temp is hot

just put trickflow heads on sbc car never ran hot before now it keeps overheating. giffin radiator, flex fan ,shroud, and electric fan, 180 t stat , the car acts like t stat is not opening. pulled and tested it and it is . tried two temp gauges. what direction should i go.. rad cloged, water pump, pulling my hair out help....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-28-2010, 04:45 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
You changed Heads only?
When does it run Hot? Crusing? Stop & Go traffic?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-28-2010, 06:56 PM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Tri-Cities, Washington
Age: 67
Posts: 5,151
Wiki Edits: 9

Thanks: 86
Thanked 122 Times in 114 Posts
Thermostat installed right side up?
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-28-2010, 09:23 PM
never satisfied's Avatar
Registered User
 
Join Date: Aug 2010
Location: lehigh valley
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
heads, roller cam , just running hot all the time now sitting idiling in driveway 260 going to test gauges tomarrow agian, thinking impeller broke in waterpump
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-28-2010, 09:56 PM
Registered User
 
Last photo:
Join Date: Nov 2003
Location: oklahoma
Age: 32
Posts: 250
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
if it is a sbc 400 the heads may need steam holes drilled?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 08-28-2010, 10:00 PM
never satisfied's Avatar
Registered User
 
Join Date: Aug 2010
Location: lehigh valley
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
no it is a 350 bored 40 over water pump is a rebuild with less than 200 miles on it not leaking at all
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 08-28-2010, 11:49 PM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
What application did you ask for when you got the Pump?
Didn't get a Reverse flow Pump by mistake did you? Or running a Standard flow direction Pump with Serpentine belt would give the same results.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 08-29-2010, 09:54 AM
never satisfied's Avatar
Registered User
 
Join Date: Aug 2010
Location: lehigh valley
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
still not sure

just pulled pump looks ok flushed block and rad with hose water seems flow threw everything nice going to get a new pump and thermostat for it .. another question is i put centerbolt heads on a 72 block just drilled center intake holes to fit the heads the blocks r the same right?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How Does A Thermostat Work? cobalt327 Hotrodding Basics 16 03-16-2010 06:32 AM
Engine ran hot during break-in. What are my options? V8 Super Beetle Hotrodding Basics 42 02-14-2010 06:52 PM
Identifying water pump configuration ron2424 Engine 18 05-08-2008 12:29 PM
Ideal Engine Temp? How hot is TOO hott? JAHamilton Engine 4 10-09-2005 03:58 PM
hot side, 350 tpi engine runs hot on one bank? Ellisb Engine 16 10-27-2002 06:28 AM


All times are GMT -6. The time now is 02:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.