Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   enough radiator? (http://www.hotrodders.com/forum/enough-radiator-183504.html)

sam_bo3 08-28-2010 10:10 PM

enough radiator?
 
I have a 375ish hp 350 .040 over 9.5c/r. I installed it after the first motor went bad. same hp out of a 327 11 c/r. It ran hot too but not like the new motor. The new motor over heats if it is above 40 degrees going down the highway. I put a measuring tape to the radiator. It is a 26W x 18T x 1in thick. The fins are actually 21inches wide. It is a Be Cool radiator. I have 2 electric fans pulling with no shroud. I just want to make sure before I build a shroud that I have enough radiator to start with.

techinspector1 08-29-2010 02:49 AM

Quote:

Originally Posted by sam_bo3
I have a 375ish hp 350 .040 over 9.5c/r. I installed it after the first motor went bad. same hp out of a 327 11 c/r. It ran hot too but not like the new motor. The new motor over heats if it is above 40 degrees going down the highway. I put a measuring tape to the radiator. It is a 26W x 18T x 1in thick. The fins are actually 21inches wide. It is a Be Cool radiator. I have 2 electric fans pulling with no shroud. I just want to make sure before I build a shroud that I have enough radiator to start with.

I'm no engineer, I just try to figure stuff out. If we went back a few years to 1968, when motors really howled, we would find that the 1968 Camaro 396 (guesstimate 375) used one of two different radiator sizes, either a 391 square inch (23" x 17") or a 368 square inch example (26" x 16"). Now, not only because I don't particularly like electric fans, but back in those days, the factory engineers used 18", 7-blade steel fans with full shroud and usually, a thermostatically-controlled fan clutch. I can't answer to your electric setup performing as well or better than those earlier systems, but it does make sense to me that you would want as many square inches of area in your radiator as the factory engineers provided for motors of about the same hp output as yours.

SSedan64 08-29-2010 06:01 AM

That doesn't sound like an air flow problem. Going down the highway the fans aren't really needed.
Have you checked to make sure the lower hose isn't collapsing? Spring inside hose? Thermostat opening?


All times are GMT -6. The time now is 11:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.