Few new pics in my gallery more on the way - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-15-2004, 02:03 PM
Jag Daddy's Avatar
British Style with USA Muscle
 
Last photo:
Join Date: Mar 2003
Location: Valencia, California
Age: 57
Posts: 1,078
Wiki Edits: 0

Thanks: 7
Thanked 0 Times in 0 Posts
Few new pics in my gallery more on the way

Put up a few new picks of the new Edlebrock valve covers that came from the trade show. They'll be going on the motor tonight or tomorrow. I've been sorting out computer problems for people all week, my self included.. Let me know what you think.

Regards
Mark

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-15-2004, 04:25 PM
blndweasel's Avatar
paints everything flat black
 

Last journal entry: September 2005 - Current
Last photo:
Join Date: Mar 2003
Location: San Diego, CA
Posts: 363
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Those are sweet! are those the two-piece units?

tbw
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-16-2004, 03:07 AM
Dutchman's Avatar
Old Salt
 
Last photo:
Join Date: Apr 2003
Location: Portsmouth, Virginia
Age: 56
Posts: 491
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Jag,

Your covers



look great, did you get a good deal on them?
Looking forward to the pics of them on your engine.

Dutch
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-17-2004, 01:09 AM
Jag Daddy's Avatar
British Style with USA Muscle
 
Last photo:
Join Date: Mar 2003
Location: Valencia, California
Age: 57
Posts: 1,078
Wiki Edits: 0

Thanks: 7
Thanked 0 Times in 0 Posts
Put up another photo of the covers on the block, still need some engine dress up but thats after I get all the bugs worked out

Regards
Mark
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.