Flashers work but signals dont???? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-28-2008, 06:56 PM
SouthernRodder's Avatar
Registered User
 
Last photo:
Join Date: Nov 2005
Location: Corinth, Mississippi
Age: 29
Posts: 79
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Flashers work but signals dont????

68 Firebird. My signal lights will not work. Flashers work properly. Brake lights and back up lights all work. All fuses appear to be good. Horn works. I just don't know what else to check. The switch seems to work properly in the column. Please help. Any advice would be greatly appreciated.

southernrodder

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-28-2008, 07:23 PM
Member
 
Last photo:
Join Date: Feb 2003
Posts: 642
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
You should have two separate flashers. One for the hazards and another for the turn signals. You can swap them around to see if the problem follows.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front clips and frame swaps --- More work, less value Centerline Suspension - Brakes - Steering 23 05-25-2005 08:42 PM
Learned behavior. coldknock Hotrodders' Lounge 19 08-25-2004 02:50 PM
Stuff I work on at work :) esears Hotrodders' Lounge 6 09-29-2003 01:08 PM
Ever work on the impossible? johnsongrass1 Hotrodders' Lounge 16 08-20-2003 01:59 PM
no signals please help 87 350monteSS Electrical 4 07-29-2003 01:39 PM


All times are GMT -6. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.