Fluid question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-15-2004, 05:39 PM
Grumpy
 
Last photo:
Join Date: Dec 2002
Location: D.C.
Posts: 1,447
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Fluid question

I know I posted a thread in the transmission section, but I'm in a bit of a hurry.

I changed the fluid in my 87 dodge lancer today and the dealer said to use ATF + 3 like most chyslers, but after seeing the dip stick, it said use Dexron II, so which am I supposed to use.

This can go to the dump, or be moved, sorry in a real hurry with this POS, really need the help!

Thanks.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-15-2004, 08:20 PM
Nightfire's Avatar
Young & Idealistic
 
Last wiki edit: How to rebuild an engine
Last journal entry: 1950 Fargo - losing hope
Last photo:
Join Date: Mar 2004
Location: Canada
Age: 26
Posts: 1,192
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
^^^^
BUMP
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-16-2004, 10:38 AM
Tazz
 
Last photo:
Join Date: Jun 2001
Location: amherst,ohio
Age: 66
Posts: 2,049
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
trans fluid's

Unless the ATF + 3 is a direct replacement for the Dexron II you should change the fluid and install the correct fluid in the trans and hope you didn't do any damage. You might want to change the filter too. I always try to install whats it says on the dipstick if I can.


Tazz


Rat Rods Rule!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-16-2004, 06:30 PM
Grumpy
 
Last photo:
Join Date: Dec 2002
Location: D.C.
Posts: 1,447
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Well see, thats what the problem is, I dont know what is the correct fluid to use.

But I think I'm gonna stick with ATF + 3, it seems to run much better. I mean I can really tell the difference.
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.