Ford 302, misfire at idle & light throttle - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 01-30-2013, 10:32 PM
Registered User
Join Date: Nov 2005
Location: Birmingham AL
Posts: 44
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
Ford 302, misfire at idle & light throttle

1970 Mustang, stock 302, aluminum intake, Summit 600 CFM carb, stock distributor w/ Pertronix conversion, Flamethrower coil.

Random, regular misfire at idle and light throttle.
Runs perfect under a load or wide open.

Varied initial timing.
Confirmed and varied 12V power to the coil.
Varied the gap for the Pertronix pickup.
Varied carb settings.
No spit, sputter, backfire.

Confirmed no vacuum leaks.

Confirmed proper ignition advance.

Can it be as far fetched as a lifter not pumping up at idle, therefore not opening the intake valve far enough?

All ideas appreciated.

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 01-31-2013, 01:21 AM
JeffB's Avatar
Registered User
Last photo:
Join Date: Jul 2006
Location: Phoenix,AZ
Age: 69
Posts: 2,033
Wiki Edits: 0

Thanks: 4
Thanked 138 Times in 125 Posts
Watch this video:
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
70's 350 Misfire under light/medium load danderduff Engine 22 07-26-2012 12:40 PM
Misfire at idle/acceleration 91CamaroDude Engine 5 03-27-2012 09:22 AM
Idle misfire ????? motoxracer Electrical 5 03-13-2006 06:49 AM
Throttle Control..Cable / Lever & Rod/ Or Electronic ( Throttle By Wire) Viet Nam Vette Engine 4 06-13-2005 05:29 PM
92 ford 302 EFI wont idle cgreene General Rodding Tech 5 11-05-2003 09:50 PM

All times are GMT -6. The time now is 12:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.