Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Fresh 383 burns up pistons
View Single Post
  #1 (permalink)  
Old 03-21-2012, 07:15 PM
brad33478's Avatar
brad33478 brad33478 is offline
Registered User
 
Last photo:
Join Date: Dec 2011
Posts: 25
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Fresh 383 burns up pistons

had a 383 stoker built for me a few weeks ago, iron vortec heads, 10:1 speed pro pistons and eagle crank etc. Well swapped it into my truck and put about 90 miles of driving here and there and started blowing oil out of the breathers severely. Checked compression and had two cylinders at normal around 175 and the rest were pretty much junk, around 30-80. Well sent the motor back under warranty and heres some pics of the damage. He first accused me of using NOS which I never have and probably never will. He believed me and is covering all the parts/labor but my question is what could cause this much damage?
engine never overheated
had consistent oil pressure
my spark plugs read normal
headers never got excessively hot
and I have a brand new holley 750 on top with 7psi supply giving it plenty of fuel

the only thing I did before it started blowing oil out the breathers was mess with the timing with a different timing light, cause ignition timing cause this much damage in such a short time?
Attached Thumbnails
Click image for larger version

Name:	photos 1647.JPG
Views:	2055
Size:	485.7 KB
ID:	64197   Click image for larger version

Name:	photos 1648.JPG
Views:	1485
Size:	469.5 KB
ID:	64198   Click image for larger version

Name:	photos 1652.JPG
Views:	1395
Size:	473.5 KB
ID:	64199   Click image for larger version

Name:	photos 1653.JPG
Views:	1513
Size:	438.6 KB
ID:	64200  
Reply With Quote