Friggin Lighting Problems. Please help! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-27-2004, 03:45 PM
my350camaro84's Avatar
Smoke Tires, Not Drugs.
 
Last photo:
Join Date: Nov 2004
Location: Baltimore, MD
Age: 26
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Friggin Lighting Problems. Please help!

well guys heres my problem. I have an 84 Z29 with the H.O. 305 and I've been having real trouble with my lights. I jsut put in all new high beams and low beams yet when the normal running lights are on they both work fine but when I turn on high beams both high beams pop on and the low beam on the driver side illuminates but the other doesn't. my next problem is that my brake lights work fine but when I turn on the lights no rear running lights pop on and finally none of my interior lights (cluster panel, radio, a/c heater switch, Gearshift) will illuminate. I've been told that a faulty light switch may be the problem but it's not the easiest thing to get to so I wanna be sure thats the problem before I try and get to it. I would really love to know the answer to this because then I can get my car inspected. Thanks Alot!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-27-2004, 03:48 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,864
Wiki Edits: 5

Thanks: 20
Thanked 250 Times in 203 Posts
I would say it's a number of ground problems. Check out the grounds at the sockets and the engine to chassis grounds.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-27-2004, 03:54 PM
my350camaro84's Avatar
Smoke Tires, Not Drugs.
 
Last photo:
Join Date: Nov 2004
Location: Baltimore, MD
Age: 26
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thanks. I never really thought too much about that. I'll clean the grounds out tommorow and tell ya what happens. but any other suggestions are welcome.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-28-2004, 05:16 PM
my350camaro84's Avatar
Smoke Tires, Not Drugs.
 
Last photo:
Join Date: Nov 2004
Location: Baltimore, MD
Age: 26
Posts: 155
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
well I cleaned out all the grounds and poof nothing happened. all the bulbs are good and I just bought a new light switch and I'll install that to see what happens if anyone would have any idea please let me know I'm at my wits end.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.