Fuel delivery on my pontiac 400 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-02-2004, 08:22 AM
midget66's Avatar
Registered User
 
Join Date: Aug 2003
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Fuel delivery on my pontiac 400

I have never had a car older that 5 years and just bought a 1979 firebird with a 400 from a 72 t/a. It has a performer intake with a demon carb headers. My fuel pump is a mr gasket mech type with 2 holes labeled in and out and a 3rd hole blocked off. I look at the fuel filter and it seems to just trickle through at any rpm. Shouldn't this filter be full of fuel? Also, now that the warm weather has hit, the car stalls and dies when driven in traffic. When this happens, it takes about 30 to start again. I am really enjoying working on this car but I'm a little confused about this 3rd hole in the fuel pump and the air in the fuel filter. Any help would be appreciated.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-02-2004, 08:34 AM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,168
Wiki Edits: 0

Thanks: 26
Thanked 279 Times in 259 Posts
The air pocket in the see thru gas filter is normal. The stalling problem as you know isn't. The third line on the pump is for the return line to the tank. Being a modified engine/car someone probably removed the evap canister and plugged off the original return line. The stalling problem sounds like flooding. Is this carb by chance a double pumper? and is the car an automatic trans with stock rear gear?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-02-2004, 10:45 AM
midget66's Avatar
Registered User
 
Join Date: Aug 2003
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
The Carb is a 625 Road Demon. The Tranny is a TH400 and the rear end is stock. I checked the sight glasses on both the primaries and secondaries, both float bowls were empty.
Could this possibly be vapor lock? If so, what can I do about it.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.