Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Fuel Line Issue into TBI... PLEASE HELP! (http://www.hotrodders.com/forum/fuel-line-issue-into-tbi-please-help-185477.html)

350chevypower 10-03-2010 09:29 PM

Fuel Line Issue into TBI... PLEASE HELP!
 
Hey,
Yesterday I rebuilt my throttle body on my 93TBI motor. Naturally I had to take the fuel inlet plug out and fuel outlet plug also to take of the fuel regulator, injectors, etc... Anyways that went all fine and dandy put everything back together and realized now that im leaking fuel out of the fuel inlet plug where it threads into the Throttle Body. Before it was leaking pretty good now i got it to just a drip but still very dangerous as its running down my intake and fairly close to the headers..=FIRE... I dont wanna be stranded on the highway somewhere or in traffic with my motor on fire... Anyways ive tried everything... I went down even to the wreckers and got another plug but still no dice... the little plastic seal is on there as well so i know its not that..... now couldhave the threads stripped as i was taking it out/putting it in? It doesnt seem like they have as I can thread it in nicely and and gets tight/snug like it should? Would teflon tape work? I know the white kind wouldnt but dont they make a another brand for fuel and or other fluids? I am stumped :smash:

richard stewart 3rd 10-11-2010 12:34 PM

Hi,
The white tape will work, don't go crazy with it one wrap should do it.
Good luck,
Rich

FastOrange 10-11-2010 10:58 PM

i would try one or two wraps of tape like mentioned above. Still, i have ran those fittings before without seals and never had leaks, wonder if you stripped something.

ChevyTruckGuy 10-12-2010 12:20 AM

Your missing the gasket that sets on the inside!

Craig

va4cqd 10-12-2010 05:19 AM

gas eats teflon tape

350chevypower 10-12-2010 08:24 PM

Well Turned out to be the threads in the throttle body indeed WERE stripped.Shoulda of been more careful putting it back in. A trip down to the wreckers got me the LAST one there! :thumbup: all is good now.... TOA.. when threading in anything make sure its going in STRAIGHT and u can spin it easilly!!! :spank: I guess I actually forced it in causing leakage!


All times are GMT -6. The time now is 07:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.