Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Fuel problem (http://www.hotrodders.com/forum/fuel-problem-2016.html)

Bayfrog 10-23-2001 05:57 AM

Fuel problem
 
I have a Streetrod with a 350 ZZ4 engine, Complete Edelbrook setup, intake, dual 500 carbs, and manual fuel pump.My problem: the car runs great in town (slow or fast). When I go on a run of 50 miles or more, crusing at 65 all of a sudden it acts as if it has run out of fuel (same sound). You can feather it and it will sometimes clear up for a while. Most of the time it will die. I can pull to the shoulder, wait 3 minutes, start the car up and it will run fine for another 15 minutes or so, then same story. If I get off the Interstate it will run o.k. in stop and go traffic.The car has coil-overs and takes a bump pretty hard. Any suggestions? Thanks, Steve

23 Bucket 10-23-2001 08:53 PM

I had a simular problem. The problem was that my fuel pump was putting out too much fuel pressure. For $20.00 I got a fuel pressure regulator, set it at 5 pounds and my problems were gone!

R2SPEEDRACER 10-24-2001 02:04 AM

I thought feul pressure was suppose to be 7 pounds as the last reply was check fuel pressure probably will be you answer


All times are GMT -6. The time now is 08:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.