Fuel pump - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-02-2011, 06:27 PM
Registered User
 
Join Date: Feb 2011
Location: indianapolis,IN
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Fuel pump

I just installed a new Bosch fuel pump two starts later with in a hour pump quit working could the pump have been defective. Installed on a 1992 Chevrolet K2500 all wires hooked up right grounded off the frame like it should be any suggestions. I checked fuse and fuel relay.

    Advertisement

Last edited by Big A's 78 chevy; 03-02-2011 at 06:29 PM. Reason: Adding information
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-02-2011, 06:52 PM
Registered User
 
Last photo:
Join Date: Apr 2010
Location: Sand Rock
Posts: 392
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
if it is i dont think you can get your money back, i went through that on a 1989 mustang GT i had (Awsome car), the part store told me after installed i cant get my money back though its possible to have a defective pump...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-02-2011, 08:57 PM
Registered User
 
Join Date: Feb 2011
Location: indianapolis,IN
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks: This pump i got has a lifetime warranty on it so hopefully they will exchange it. Also the pump i got is a Bosch it had a hole in it for a small bolt on the top do you know what that would be for.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 gmc jimmy fuel pump won't shut off/fuel pump relay garystrosnider Electrical 7 10-28-2010 07:10 AM
Fuel Pump Not Sending Gas To Carb Why?? Its Not Electric Fuel Pump???? zeeman19 Engine 7 02-13-2007 03:17 PM
Inline fuel pump vs. in tank fuel pump wheel-7 Engine 2 09-02-2006 06:57 AM
TPI 350 fuel pump *VERSUS* a Multiport 2.8L fuel pump boneyard Buick Engine 8 06-04-2006 11:56 PM
TPI 350 fuel pump *VERSUS* a Multiport 2.8L fuel pump boneyard Buick Engine 0 03-18-2006 09:40 PM


All times are GMT -6. The time now is 07:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.