Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Fuel Pump Making Loud Noise
View Single Post
  #7 (permalink)  
Old 08-24-2006, 03:41 PM
fitzwell fitzwell is offline
Member
 
Last photo:
Join Date: Jul 2005
Location: texas, earth
Posts: 420
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by xntrik
I eliminated the sock filter on the inside tank pickup tube. Installed an inline metal 3/8 filter (like a GF-2 but in 3/8) in the suck line, and the stock Ford inline filter on the pressure side using the factory frame bracket also. I use the snap on type factory fuel line fittings everywhere, so the installation is fully factory compatable. The pump is mounted high up behind the differential on the trunk floor doubler brace and is no problem because the original tank's delivery system comes out the top of the tank anyway. It primes perfectly every time.

Never had one minute's trouble in 58,000 miles on one car, or on any car. yet.

I use the original fuel tanks and the only problem I have is that on a maximum effort launch with less than 1/2 tank of fuel the original tank pickup uncovers and I get fuel starvation about 40 feet out of the hole. So when I race, I make sure the tank is full.

Just my experience. Did the first 5.0 SFI conversion back in 92.


www.readershotrods.com
whatever works for you....most of those pumps are designed to push, rather than pull fuel.Mine is mounted slightly above mid-tank level, about 18'' away from the tank outlet. Ran into an issue with the small inline filter before the pump recently...put a large inline filter before the pump....problem solved. not right or wrong........i'm just sayin
Reply With Quote