fuel pump shuting off while engine is running.. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-27-2012, 04:33 PM
Registered User
 
Join Date: Jan 2010
Location: South dakota
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
fuel pump shuting off while engine is running..

Ok I have a 84 firebird that some body put a carbed 350 with a edelbrock performer and with a external electric fuel pump ran by a toggle switch and it pumps gas but once the car is running it stops pumping? Im confused what would cause this?? I bought the car about a month ago and it ran fine until yesterday.. Any ideas?


any ideas how i could re wire this?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-27-2012, 10:13 PM
Registered User
 
Last photo:
Join Date: Jan 2011
Location: Hopewell, Va
Age: 62
Posts: 1,219
Wiki Edits: 0

Thanks: 0
Thanked 120 Times in 116 Posts
fuel pump shuting off while engine is running..

How about a little more info on the fuel pump. What brand pump is it? Where is it mounted? It should be mounted in the rear of the car below the tank. You should have a 100 micron filter between the tank and the pump. It can be wired to a toggle switch or wired to the ignition switch. I prefer the ignition switch so it turns on and off with the key. There should be an 30 amp fuse on the +12 volt wire to the pump. Make should you have a good ground to the pump.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-27-2012, 10:32 PM
Registered User
 
Last photo:
Join Date: Jul 2012
Location: Russellville, Arkansas
Age: 51
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
put a mechanical pump back on it
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-28-2012, 02:46 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
I recommend using a Relay & Oil Pr. safety switch.
Most likely a bad Toggle switch, Pump or loose wire.
Several wiring diagrams & cleaning instructions here, if Holley type.:
http://static.summitracing.com/globa...199r7914-2.pdf
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-28-2012, 06:51 AM
Registered User
 
Join Date: Jan 2010
Location: South dakota
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I'll try to get some more info on the pump (if i remember right it is a holley) its mounted in the rear of the car below the tank and right now the toggle switch pretty much controls everything (spark and fuel) I really want to ditch the toggle switch but im clueless when it comes to wiringso ill look in to those diagrams and see what i can figure out. Thanks guys!
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 09-28-2012, 09:04 AM
Registered User
 
Last photo:
Join Date: Jan 2011
Location: Hopewell, Va
Age: 62
Posts: 1,219
Wiki Edits: 0

Thanks: 0
Thanked 120 Times in 116 Posts
electric fuel pump wiring harness

Jegs has a reasonably priced wiring harness for your electric fuel pump. JEGS Performance Products 10564 JEGS Fuel Pump Harness and Relay Kit Here is the instructions for the wiring harness. http://www.jegs.com/InstallationInst.../555-10564.pdf Looks like it would be an easy installation.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 09-28-2012, 05:02 PM
Registered User
 
Join Date: Jan 2010
Location: South dakota
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I got it figured out fuel gauge does not work and was out of gas Thanks for the help guys im be sure to use the links you pointed me too.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
96 k1500 running out of fuel bad pump or no fire??? Dagwood03 Engine 7 08-05-2011 11:27 AM
fuel pump keeps running! hitecsedan Electrical 3 09-18-2009 11:38 AM
fuel pump running but no gas to carb? dhomsey Engine 2 07-30-2008 01:16 PM
Sunfire, died and wont start back, fuel pump is running, no gas getting to filter jordan2011 Engine 6 04-21-2008 06:01 AM
Key Off Fuel Pump Running greg67 Electrical 4 05-16-2005 08:49 PM


All times are GMT -6. The time now is 12:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.