gas smell hard start - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 04-05-2007, 08:38 PM
Registered User
Join Date: Mar 2007
Location: sheboygan wisconsin
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
gas smell hard start

I have a problem with an 1989 chevy astro van. I replaced the 4.3 with a rebuilt 350 its got headers fuull dual exaust with some cheepo turbo muffs a edelbrock performer intake edelbrock 550 carb everything else is stock I can smell gas when it is shut off after driving it and yes the charchol? filter is hooked up. it also starts like it's flooded Ihave to hold the gas pedal at least halfway down to restart after driving. when it,s running it runs great lots of power even with stock spec cam. One thing idid not remove the stock fuel injection fuel pump in tank tbi ijust disconnected the wire for it could this be the problem? it has ran like this for over two years. even with the stock v-6 trans that everyone said wouldn't work why the he$# does it start like that? ive check float level. the plugs look great i don't getit any help would be great thanks

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 04-06-2007, 05:28 AM
sharkmonkey's Avatar
1973 Regal 455
Last photo:
Join Date: Apr 2006
Location: Westerville, OH
Age: 45
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Are the gaskets in the carb good? Can you see or feel gas leaking anywhere around the carb? How's your air filter? Maybe the A/F ratio is set too rich.

As far as hard starts, your timing may be set too retarded or you have a vacuum leak (or both). Could be a choke issue too. Do you have an electric, manual or divorced choke?

I'm just throwing things out that have bit me in the past.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
gas prices 69novarodr Hotrodders' Lounge 27 04-17-2009 09:47 AM
Gas Smell . .& not baked beans! TheBreeze Engine 2 02-09-2008 08:32 PM
hard to start MARK TINNELLY Engine 7 01-13-2006 12:12 PM
Is treated 3yr old gas ok to start a new engine on? Malibu73 Engine 11 11-02-2005 02:35 PM
Hard Start Question Jim Weeks Engine 6 03-19-2002 04:30 AM

All times are GMT -6. The time now is 04:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.