Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - GM 3.1L Cooling issues and cooling fan
View Single Post
  #1 (permalink)  
Old 01-21-2012, 04:25 AM
pickled_asparagus's Avatar
pickled_asparagus pickled_asparagus is offline
Registered User
 

Last journal entry: 1969 Olds Cutlass conv. build
Last photo:
Join Date: Dec 2011
Location: Milwaukee, WI
Age: 30
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
GM 3.1L Cooling issues and cooling fan

Ok, so I've been having trouble understanding what's going on here. Vehicle is a 1995 Olds Cutlass Ciera SL 3.1L. Normal operating temp is the guage at 1/2. Lately it's been creeping up to almost 3/4 when I'm at 65-70 mph. So far, I've replaced the heater core (box was full of coolant and it smelled in the car), and just finished fixing the leaking lower intake gaskets today using the steel fel-pro ones (FUN!!). Head gaskets seemed fine, no cylinder pressure in the radiator or coolant in the oil/vice versa. New T-stat also. I'm assuming all the air bubbles are out (maybe not?) but the heat blows warm for the most part. Does anyone know the proper "bleeding" procedure for these?

Also, When is the cooling fan supposed to come on? It seems like I let the car idle forever and the fan never kicked on. I do live in Wisconsin and it's 10 degrees outside but I would think the fan would kick on. At idle, temp is fine and stays steady at 1/2. Does the fan ever come on on the freeway or is it only at idle/slow speeds? Like I said, the car never really overheats, but i dont ever remember it running like this. Any help would be greatly appreciated!

Thanks!
Reply With Quote