Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   GM Tilt Telescopic Steering (http://www.hotrodders.com/forum/gm-tilt-telescopic-steering-224789.html)

27Tall T 10-07-2012 09:15 PM

GM Tilt Telescopic Steering
 
:welcome:I have a early '70's Cadillac tilt, telescopic steering where the turn signal does not go into the right signal indent. I push the lever down to get the left signal indent, and it does, but when I push the lever up to go into the right signal indent, the lever runs out of room and hits the column hub before it will go into the indent. I've taken the wheel off and used a screwdriver to place it into the detent, thinking it was a bit of dirt, but when I try to repeat the process I still cannot get it to go into the signal position without using the screwdriver to coax it into position. Is there a quick fix for this or does the signal unit have to be replaced even though it functions as it should except going into the right signal position?

enjenjo 10-08-2012 11:54 PM

Look at the turn signal switch on the right side of the column, at the detent. There should be two mousetrap looking springs on the top. If one is missing, it can cause your problem, or if the tab that holds the spring under tension is broken, same thing. You can replace a missing spring with one from a junker, but if the tab on the switch is broken, you will have to replace the switch.

27Tall T 10-09-2012 08:26 AM

:welcome: Thanks for the reply. Took the wheel lock off and got at the switch and saw the two "mousetrap" springs and they are both fine. Cleaned them off, lubricated with a little grease and the switch started to work fine until I put the wheel lock back on and the "C" clip. Then it did the same thing.....wouldn't go into the right signal dedent. Took the lock off and tried the switch.....worked again until the lock was placed back on with the "C" clip. Something has got to be brushing against the switch, don't you think?:confused:

enjenjo 10-09-2012 09:15 PM

You have the lock plate clocked correctly? It only works right in one position.

It might be bent too.

27Tall T 10-09-2012 09:32 PM

:DTook it apart again, removed the screw that held the formed metal which connected to the turn signal arm and checked this piece of metal to see it it was bent in any way. Seemed okay and replaced everything as it should be. Put the lock plate back on and now it works! Why, who knows? Have no idea what the problem was other than just saying that something was misaligned. Thanks to all that helped.:thumbup:


All times are GMT -6. The time now is 06:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.