goodwrench 350 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-10-2012, 12:23 AM
Registered User
 
Join Date: Feb 2008
Location: kansas
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
goodwrench 350

i have a 350 goodwrench engine out of a 94 chevy truck. the block has a boss for a mechanical fuel pump, if i get the block machined for a mechanical fuel pump and use a cam that has the lobe for a mechanical fuel pump will i be able to use the pump? i really dont wanna use a electrical fuel pump. im putting the engine in a 66 impala with a 200r4 trans and 342 rear gears. i was thinking of using a old edelbrock performer cam that i bought in 98. its still in the box never been used

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-10-2012, 07:51 AM
TroyBoy's Avatar
Psychomotors
 
Join Date: Jan 2006
Location: East Bonne Terre ,Missouri
Age: 49
Posts: 675
Wiki Edits: 0

Thanks: 14
Thanked 9 Times in 8 Posts
Are you sure that it isn't already machined? I have had several of these engines and they all were. Just wondering. That cam is a nice torquey cam and should move your Imp nicely.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-10-2012, 12:21 PM
Registered User
 
Join Date: Feb 2008
Location: kansas
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by TroyBoy
Are you sure that it isn't already machined? I have had several of these engines and they all were. Just wondering. That cam is a nice torquey cam and should move your Imp nicely.
i havent checked yet, the engine is in my brother in laws garage, he got it bored over 60 with trw pistons a performer intake and carb and had stainless valves installed in the heads he assembled it but never fired it, i was gonna ditch the stock cam he installed and relube everything . the goodwrench engine is for a tbi engine.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have a GM Goodwrench 350? 64_ss Engine 29 09-10-2009 01:51 PM
GM Goodwrench LM1 nootkabear Engine 14 11-08-2007 09:49 AM
Goodwrench 350 w/ TBI BadHabitSS Engine 17 07-27-2007 11:37 AM
cam 4 new goodwrench 350 Timothy Trankina Engine 14 05-03-2005 07:58 AM
GM Goodwrench 350 alex Engine 2 12-19-2004 08:08 AM


All times are GMT -6. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.