Got to drive the Impala - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-01-2005, 09:21 PM
hunt101's Avatar
Learning something every day
 

Last journal entry: Adding some tunes
Last photo:
Join Date: Nov 2004
Location: louisiana
Age: 25
Posts: 36
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Got to drive the Impala

I finally got to take my car out for a test drive today. I got my engine running right and exhaust done. I put my dash together yesterday got a few other things put back together. It was my first time doing any wiring so some of the things dont work like the blinkers, horn, ac, and windsheild wipers. My headlights and taillights still dont work and there are a few more things I need to do before i get insurance and start driving the car every day. Today I took the car out for a few runs around the neighborhood to check things out and get a feel for the car. The car ran pretty good but it did cough a little when i would jump on the gas (my mistake, 600cfm carb on stock 283 ) but other than that it ran perfect. I still need to get the steering tightened up and the front end aligned for it to drive just right. It was a lot of fun to drive and it definitly got a lot of looks (not all good). Here are a few new pics of the car. Please ignore the piece of cardboard under the car
Attached Thumbnails
Click image for larger version

Name:	engine 001.jpg
Views:	79
Size:	60.2 KB
ID:	7644   Click image for larger version

Name:	Oct 05 037.jpg
Views:	79
Size:	152.3 KB
ID:	7645   Click image for larger version

Name:	Oct 05 038.jpg
Views:	61
Size:	141.6 KB
ID:	7646  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-01-2005, 09:35 PM
66GMC's Avatar
Get in, sit down, hang on
 

Last journal entry: Cab Removal
Last photo:
Join Date: May 2005
Location: Olds, Alberta Canada
Age: 57
Posts: 2,761
Wiki Edits: 0

Thanks: 32
Thanked 90 Times in 85 Posts
That's gonna be a nice little car when you get it done right.

I know you're anxious to get her rolling, but take your time and make sure it's SAFE. It would be an awful shame to crash or burn it up due to electrical problems.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-02-2005, 02:13 PM
1eyedjak's Avatar
Member
 
Last photo:
Join Date: Mar 2005
Location: Seattle, WA
Age: 36
Posts: 41
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nice Impala , what year? I have a 69
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-02-2005, 02:17 PM
WakBordr7387's Avatar
Gone fishin'
 
Last wiki edit: Removing stuck fasteners
Last journal entry: blah.......again
Join Date: Sep 2004
Location: Texas Coast
Age: 29
Posts: 667
Wiki Edits: 2

Thanks: 0
Thanked 0 Times in 0 Posts
Nice job dude, and thats a good looking impala too.



Brad
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-02-2005, 05:40 PM
steve t's Avatar
ex biker, now hotrodder
 
Join Date: Mar 2005
Location: NC
Age: 64
Posts: 863
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nice 62, 600 carb is ok for 283, thats what i have on mine 61
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 11-02-2005, 08:06 PM
Nightfire's Avatar
Young & Idealistic
 
Last wiki edit: How to rebuild an engine
Last journal entry: 1950 Fargo - losing hope
Last photo:
Join Date: Mar 2004
Location: Canada
Age: 26
Posts: 1,192
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
SCHWEET!!!!!! way to go man, that oughta be a fun car.




Mike
Reply With Quote Quick reply to this message

Recent Hotrodders' Lounge posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to remove tach drive from distributor ? dastone Engine 2 08-23-2005 06:10 AM
crossmember and drive shaft trouble rbaughman Hotrodding Basics 6 04-06-2005 04:17 PM
Erson Gear Drive Woes blndweasel Engine 9 07-14-2004 09:53 AM
Swapping Gear Drive Out for Timing Chain or Belt Drive - Need Suggestions horvath Engine 4 05-24-2003 08:47 PM
front drive shaft in bronco 2 steve norman Transmission - Rearend 2 10-19-2002 11:11 AM


All times are GMT -6. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.