got a problem with my tranny - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-21-2003, 02:31 PM
Registered User
 
Join Date: Mar 2003
Location: Minot, ND
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Red face got a problem with my tranny

I own a 1993 Ford Thunderbird LX. It is a 5.0 V8. My M.O.D. (manual over-drive) has gone out. I have gone to some transmission shops and they say that the only way to fix my problem is to get a new or rebuilt tranny. I was going to have my fluid and filter changed but the mechanic stated that it would do no use. I have a feeling that my tranny pump has gone out. Would my problem be fixed with buying and replacing the tranny pump? If you would be so kind as too help me out, I would really appreciate it. Please feel free to contact me either through here or on my personal e-mail at bones6537@yahoo.com. Thank you.

Robert Jones
U.S.A.F

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-21-2003, 02:41 PM
Member
 
Last photo:
Join Date: Sep 2002
Location: USA
Posts: 490
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Post

MOD?
What the hell is that?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-21-2003, 03:44 PM
dmorris1200's Avatar
doesn't play well with others
 
Last photo:
Join Date: Feb 2002
Location: Maine
Age: 49
Posts: 1,834
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

[quote]Originally posted by Jason:
<strong>MOD?
What the hell is that?</strong><hr></blockquote>
Used to be a hardcore band back in the early nineties.

__________________
BUILT FORD TOUGH
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-22-2003, 05:13 AM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,117
Wiki Edits: 0

Thanks: 25
Thanked 266 Times in 249 Posts
Post

Sorry to say, replacing the fluids, filter and front pump won't work, its expensive rebuild time!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-22-2003, 07:41 PM
mustang66maniac's Avatar
Ford Freak
 
Last photo:
Join Date: Feb 2002
Location: Rockville, MD
Age: 30
Posts: 676
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

MOD? Ive never heard of such a thing. Its most likely an AOD as theyve never put manual transmissions in thunderbirnds. Furthermore, manuals dont have filters and pumps. You'll need a full rebuild if its gone out. I bought the rebuild kit for my AOD for $260, itll be more if you have someone do it for you.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.