ground strap over thinking - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-11-2007, 03:42 PM
Registered User
 
Join Date: Jun 2007
Location: plano texas
Posts: 374
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ground strap over thinking

Ok I might be over thinking this. I read in a mag that I need a ground strap from the firewall to the engine and an aluminum head was ok. I did the ground strap but was wondering if my black oxide studs in the block would cause a bad ground?

I have a trunk battery with it grounded to the frame. I have a ground strap from frame to block. I just installed a ground strap from firewall (brake booster bolt sandwiched to bare mettle on firewall) to the head. Does this look ok? I have had starting issues in the past due to an old alarm and a jump in the tach at 1000-1500 rpm but nothing else. I have 14.5 to 15 volts. I have my grate grandfather's 55 chevy and I don't think it ever had ground straps.

Thank you for your help,
The Tom

    Advertisement

Last edited by tomthecomic; 08-11-2007 at 03:44 PM. Reason: spelling
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-12-2007, 08:17 AM
Registered User
 
Join Date: Jul 2007
Location: New Hampshire
Posts: 725
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Ground strap

That sounds ok. If you have any doubts do a voltage drop test from the ground terminal on the battery to wherever in the system. Ideally you shouldn't see more than .2 volt while loading the circuit you're testing.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Positive ground maddogmodl Electrical 15 02-03-2007 10:49 AM
Running a proper ground (total rewire) murrsue Electrical 6 01-23-2007 07:04 AM
wiper motor won't run cboy Electrical 14 05-03-2006 09:44 AM
what stereo wires under carpet? bullheimer Electrical 19 05-06-2005 06:37 PM
Ignition Trigger Ground Noise TurboS10 Engine 12 02-28-2004 10:44 AM


All times are GMT -6. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.