Grounding regulator, ign relay, ign module? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-26-2005, 08:44 PM
cboy's Avatar
Member
 

Last journal entry: Finished
Last photo:
Join Date: Jan 2004
Location: Atwater, CA
Age: 69
Posts: 3,918
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 4 Posts
Grounding regulator, ign relay, ign module?

Is there any need to ground the metal cases on the regulator, ignition relay and ignition module? I ask because these are normally mounted directly to the metal body of the car and would thus be grounded - should a ground be required. To keep my firewall a little cleaner I am mounting mine to the inside of the wooden base supporting the car seat - and therefore the metal cases will not be grounded. I suppose this question would also apply to folks mounting the same items on a fiberglass bodied car.

    Advertisement
__________________
Always learning...and sharing what I've learned. The Scratch-Built Hot Rod.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-27-2005, 04:36 PM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Ground

Doc here,

I would Run a Ground Lug on the mounting Board.

The regulator for sure needs a ground...

Run 1 main #10 black wire from your ground cable to a lug on the board, then independent grounds to the components from there..you should be all good!

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1980 TA choke relay jdcoic Electrical 17 05-16-2013 07:09 PM
Omg, Car Fire!! Malibu1980 Electrical 21 06-16-2004 12:34 PM
Olds 98 Ignition Module Problems awbazar Electrical 1 01-12-2004 06:42 AM


All times are GMT -6. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.