Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   GT350 with CFI stalls (http://www.hotrodders.com/forum/gt350-cfi-stalls-149448.html)

Bubblehead 12-09-2008 07:08 AM

GT350 with CFI stalls
 
I have a 84 Mustang GT 350 20th anniversary model with CFI and when I slow down to turn or stop, it sometimes dies. It starts right back up, but it does die. I have done a complete tune up and replaced everything that should fix it, but it persists to do this. Also, at highway speed I think I feel it "surging" sometimes. I think this is the only car that Ford put CFI on so it is hard to find anyone who knows anything about this set-up. Any suggestions? :confused:

techinspector1 12-09-2008 12:12 PM

I've found in the past that it's money well spent to purchase the factory service manual(s) for the car I'm working on. This looks to be a good set of manuals and they're a steal at $40. You could email the seller and ask if CFI diagnosis is covered to make sure before you purchase them....
http://cgi.ebay.com/ebaymotors/1984-...RCHQ3aUSQ3a102

Bubblehead 05-15-2012 12:33 PM

84 GT350 with CFI stalls
 
I still trying to fix my problem. Always starts easy when cold but has problems after a short warm up of 5 miles or so.... I just put on a new fuel pump and fuel filter but it still stalls when I slow down. Has no effect on highway speeds, only when I slow or stop. It dies; then after 5 minutes or less, it starts right back up and away I go until my next stop or slow for turns. Any ideas at all what I should be looking at???


All times are GMT -6. The time now is 10:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.