gusher of oil from oil pressure sensor on sbc - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-18-2012, 09:19 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 151
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
gusher of oil from oil pressure sensor on sbc

i thought the oil pressure sensor had broken because of the oil that was leaking out of the base of it, so I ran to the auto parts store and bought a new one, however it won't stop leaking from there even with some silicone in the threading

the engine seems to have way too much oil pressure and I'm not sure whats going on
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-18-2012, 10:02 PM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Tri-Cities, Washington
Age: 67
Posts: 5,151
Wiki Edits: 9

Thanks: 86
Thanked 122 Times in 114 Posts
You put Silicone or thread sealer on the threads? What's the oil pressure?? Is this a new motor?
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-18-2012, 11:18 PM
Registered User
 
Join Date: Jan 2011
Location: Hopewell, Va
Age: 61
Posts: 1,114
Wiki Edits: 0

Thanks: 0
Thanked 114 Times in 110 Posts
gusher of oil from oil pressure sensor on sbc

I have always used teflon tape (4 wraps) on the threads. BTW you didn't answer the question of how much oil pressure do you have at idle.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-21-2012, 09:56 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 151
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
well I've never seen this before

for some reason the rear of the intake didn't seal well, and through here it leaked oil profusely, about a quart every hour the engine ran

never seen something like that before

Last edited by xzero117; 08-21-2012 at 10:15 PM.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-22-2012, 01:16 PM
1971BB427's Avatar
Registered User
 

Last journal entry: Latest changes
Last photo:
Join Date: Dec 2010
Location: Portland
Posts: 1,294
Wiki Edits: 0

Thanks: 11
Thanked 184 Times in 158 Posts
Are you sure it's leaking from the sender, and not just the rear intake seal? Sounds more like it might be a blown or dislodged seal.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
oil pressure sbc dave350v8 Engine 11 07-27-2011 10:46 PM
SBC oil pressure ??? 47 Coupe Engine 2 09-04-2009 11:26 PM
Oil pressure sensor/temp wire colors? jagurit Electrical 7 04-09-2009 08:31 PM
SBC: How much oil pressure is enough? 66Chevelle Engine 3 05-12-2008 10:39 AM
SB Ford oil pressure sensor Irelands child Engine 4 09-30-2006 05:37 PM


All times are GMT -6. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.